Download

How do I disallow my Particle System from being lit?

I have smoke in my level, and it’s being lit by some lights in the adjacent room, which makes the smoke look awful – the smoke color itself is great, I just don’t want it to care about the light it receives. I’ve disabled all light channels, I’ve disabled shadow-casting (which disables all acceptlight boxes, though I disabled those too before disabling shadowcasting), I think I changed some stuff in the settings of the particle system itself (not just the actor placed in the level), but nothing seems to be working.

I did find one person online (How to Disable Translucency Volume/Lighting? - UE4 AnswerHub) who said to use a console command to disable it, but first, I think that would disable it for the entire level which I’m not sure I want to do, and second, using a console command seems much more sketchy and unreliable and easy to forget how to reverse (not to mention I don’t even know what the default value IS to change it back to).

I saw the documentation online for the Lit Translucency for Volumetric Particle Effects (https://docs.unrealengine.com/latest/INT/Resources/ContentExamples/EffectsGallery/2_F/) but I can’t find the setting they show in their screenshot of a details panel (not to mention, I don’t even know what they changed in it to create the effect in the first place).

This should be a REALLY easy thing to do, and honestly disabling all the lighting channels should’ve prevented it from happening, along with most everything else I tried. Also, since the docs.unrealengine page makes such a big deal about how big of a resource spender it is, why is this even the default setting in the first place???

Use an unlit material?

That’s so weird, I’m almost 100% sure I tried that – I think I did make an unlit material but I tried to apply it to the emitter actor itself which didn’t do anything, and I think I got distracted by something else before I changed it in the particle system settings itself, and then figured I had already tried it and it hadn’t worked. My bad – thanks for the help :smiley: