How do i disable Frustum Culling? Please its really necessary.

I need to disable the frustum culling no matter how hard and no matter what it takes to do so.
Frustum culling is culling my units that im moving in the WPO.
Im moving them in the WPO in the level, for performance reasons.
This happens because the unit is getting out of its bounds, and then when you move the camera around, it assumes the unit is not on screen.

It is not on screen, because its actual position is still the original position, though it just moved forward in the WPO. I know its confusing.

Increasing the bounds, a solution that is often suggested by other devs wont help because it comes at the high cost in performance, it has many downsides, and also ends up failing at some point if you move too much.

So the best way to fix this is to disable all frustum culling, and then in each actor i will use hide each batallion HISM manually when necessary.

Please help.

Video of the frustum culling problem happening with HISM moving in the WPO:

Bumpity bump? BUMP

Hey @SophiaWolfie! Have you checked your project settings?

To disable culling you open your Project settings, then it will be under: Engine Rendering Culling (checkbox) :slight_smile: Let me know if that’s not what you’re looking for!

Hmm, kind of surprised that increasing the bounding box of your object affects performance that much, when they are currently only cubes.

Have you tried instanced static meshes?

I would investigate about those performance issues or check instancing before doing something so drastic as disabling frustum culling, feature that any 3D engine relies upon and can cause much heavier performance issues. If you want to do that, you’ll probably need to edit the engine’s source code.

@Mind-Brain She is talking about frustum culling. The feature you are talking about is occlusion culling. Quite different actually.

Thank you.
Im not going to have my project without any culling. Im just going to disable the frustum culling and make one customly.
The cubes are instances already. The project that im showing is not the original project but a simplified test. The original uses actual characters.
So anything with bounds is not the solution.
The best solution is to disable the native frustum culling.
Please is there a way to do this? Its very necessary.

Yes im willing to change the source code if necessary. I just need to know where in the engine code is the frustum culling happening.
Even if that requires assembly.

Hey! Did anyone ever find a resolution for this? I’m having a similar issue