How do I disable all post processes entirely?

I looked up every question in the forum, but I can’t disable PostProcessing entirely. Here is my setup:

  • I disabled post process in the project settings

  • I turned off every effect in the camera’s setup

  • I use a post process volume, where I turned off everything

Still, when I start my game in standalone mod (and I press “ctrl + shift + ,”) I can see that post process is still on. I want PostProcessing to be 0.0. How can I do that?

Thank you in advance.

What specific type of post-process are you still seeing in the game?

Did you followed through every list in the world settings to disable every feature accordingly? For example Auto Exposure post-process is disabled only when Min and Max exposures are equal. Also you don’t need to use such complex approach - just setup everything via World Settings

Please find the picture of my setup enclosed.

Now I only have a camera attached to the character. I typed in 0 to all values, then I unchecked all the boxes. (Unfortunately it doesn’t make any difference.) I do know that these values are pretty low already, but the game is intended to run on android. (How to increase performance on android? - Mobile - Unreal Engine Forums - this was my main question.)

Furthermore, since I can’t check these values on android, I assume that postprocessing uses up there also more than 80% of the resources.

Here you go - this setup worked great for me and as you see there is no PostProcessing step in rendering graph.
Just setup your PP Volume as seen on the screen and disable MobileHDR in your ProjectSettings. This way all post-process features will be disabled.

BTW you could check this values in MobilePreviewer (it will gave you more accurate result for what is actually rendering on mobile) also by typing “profileGPU” as a console command

That’s weird. Works for me on Mobile Previewer (not on device) with UE 4.6

Thank you, I am going to implement these settings ASAP.

profileGPU didn’t work on the device, the game just quit every time I entered profileGPU.

I copied everything what I saw on the picture, but the post process duration did not change in the standalone game mode. When enter the same keyboard shortcut to see GPU visualizer on the mobile preview, it does not show post process.

Is the picture that you posted from a mobile preview or from a console preview? And by the way how can you type commands in the editor? (I only know this shortcut, and the stats on mobile.)

This GPU visualizer results pictured on my screenshot is from Mobile Previewer (since you’ve mentioned that project is intended for Android). The global shortcut for openning console is the same for all platforms ‘~’ (works in the viewport too).
I didn’t get how you open GPU visualizer with shortcut, but there is console command that is working on any platfrom - “profileGPU”. That’s how I get results for my test

The shortcut is “control + shift + ,”, the last one is a comma.

However, I can’t open the console command box (it turned out I have a different binding assigned, so wrong key press can’t be the cause). I have also tried opening it in the tappy chicken template, but I just can’t. Do I need maybe microsoft visual c++ to be installed on the computer?

https://answers.unrealengine.com/questions/94518/cant-open-console.html the answer for this question can’t be the solution either.

If you installed all prerequisites (it includes ms visual c++ redist too) that should be enough. That’s completely weird since console works great in any kind of Play session for me