Download

How do I disable all post process effects and get pixel perfect clarity?

Hello,

So whenever I load up my game in the editor it decreases the brightness and adds an overall muddy feel to it (See images below). I believe I have disabled all post-process effects with a global volume by taking advice from this thread here - https://answers.unrealengine.com/questions/147462/how-do-i-disable-all-post-processes-entirely.html

But for some reason this is still happening. Does anyone know what is causing this and how I can disable it and get perfect clarity as if no effects were applied? This is really starting to annoy me.

Note: I am modifying the colours of the original sprite (because this is a night time scene) using the adjustments section of the texture editor. The properties I am adjusting are: Brightness curve, Saturation, RGB Curve, and Hue. The material I am using for the sprites is just the default MaskedUnlitSpriteMaterial

b7db0a76c53f86a8e5d1a5bb259f1a433c8dc6b6.png

d4ef04128006fc648ee93feb81e5f13ab501b678.png

Bumping. Really need a solution to this.

I’ll take a wild stab in the dark here (so likely not going to help but I’ll try) in the top left “Edit” under Project settings…Rendering…Anti_Aliasing…turn that off…I know the Default TemporalAA makes they blendy/blurry…you’ve likely already done this but just in case thought I’d take a stab…

Default UE4 Editor is blurry for me too, assuming that’s the prob???

To sharpen I use r.PostProcessAAQuality = “0” set n consolevariables.ini

See this:

Well that solved one of the problems, it looks nice and clean now. However there is still a dramatic decrease in brightness (as seen in the second photo) when played in the editor, and this effect is still happening when the game is fully packaged so we know it doesn’t have anything to do with my preview settings.

Happy to hear the stab in the dark worked…but alas I’ve no guesses on the brightness difference…but hopefully all these bumps to this thread will get some eyes on it from someone who can help…
Great looking game…good luck

Not sure if this will help, but in your post process volume under “Film” set Crush Shadows to 0.0 and Crush Highlights to 1.0

Didn’t work but thanks anyway. Any other takers?

Just adjust the actual camera post process brightness value?

ps. Nice screenshot, nostalgic like oldschool Guybrush Threepwood (1990/1991 Amiga art style).

Thanks for the kind words :stuck_out_tongue:

Iv’e managed to get it looking somewhat better but it should be good for now, honestly if anything it just makes it feel more like a night scene. Thanks for your help!

Is it loading up dark or does it change over a short period of time? Auto Exposure is on by default. As far as I know you actually need a post process volume to “disable” it.

Create a post-process volume and under auto-exposure change the Min Brightness and Max Brightness to be the same value (might have to experiment with what you want that value to be).

Na Iv’e already configured auto exposure previously so it doesn’t do that. Thanks anyway.

sounds like the old tonemapper issue.

solution here might help you.

Thank you so much, that worked!

Hey @Dolphin_Taco bro Were you following a tutorial or Did it on your own? If you did it Are you self-taught or where did you learn the PixelArt from?