How do I compile HTML5?

Hey Guys
didn’t found any help on this, could someone please point me in the right direction to start compiling stuff to HTML5

I compiled the editor but the HTML5 option is grayed out


Don’t know how - but in case someone is wondering, building HTML5 is not yet available on mac / osX, only windows.

I’m on windows and I did install the emscripten SDK

Also getting this issue, I can launch it instead, but then I get this issue.

how did you get it to compile to HTML5?

How did you even get the HTML5 to show up, even if it is greyed out?

YOu need to build the editor from the source code, is not working from the editor at the moment I think you can get it to work but, still researching that

I am building the editor from the source code and it still isn’t working. I’ve installed enscripten and still cannot it show up.

Did all that. I pulled a fork from the master branch, instead of the release code, and copied in the 2 required zip files as well as the optional zip file.
A detailed note of everything I’ve tried can be found as a reply to the answerer here:


Which version of the source code are you using? I used the master fork along with the optional dependencies, then generated the project files.

Hmmm, it looks pretty similar to what I did… I did do a build with all the programs and stuff ticked in the configuration manager, though I don’t know if that would make a difference…

Totally missed that readme file though, not that’s it’s particularly clear…

Not that I recall, I’m trying a rebuild now, but it takes forever on my machine :frowning:

In your Engine/Source folder, do have HTML5 folders in your runtime and developer folders?

Alright, so I ran through those instructions as best I could (Adjusting the file path in the _internal.bat file and running the BuildThirdParty.bat) and then rebuilt the editor, now I get this when try and launch to HTML5:1
None of the buttons do anything except quit, which just froze the page for a few seconds.

Just tried cleaning the solution and rebuilding with everything checked in the ‘Configuration Manager.’ Still no luck.
I’m on a Win7 machine. When you compiled with everything checked in config manager, did you get any build warnings or errors?

Hmmm… but you have the option in the Unreal Editor to publish to HTML5?

at the moment that is NOT going to work, you’re supposed to be able to compile to html but only from source, how? , don’t know

Under packaging? Yea, it’s there, but it’s still greyed out. I suspect it has something to do with the fact that when I press File-Open Visual Studio it tries to open a file called UE4.sln, which suggests it’s not connected to the game project properly…


We have just uploaded some new documentation for HTML 5:

Please review it and see if it can help to answer any questions you may be having. Let us know if anything is still unclear.


Everything compiles ok, firefox opens but the file is not there, the html file is not being found

Make sure you’re launching in a 64-bit version of Firefox (or Chrome).

In order to have a .html file to launch, you’ll need to not only compile the project but ALSO cook/package it via UnrealFrontend.

Once you have this HTML file, you may need to host it (and all data files) via a server stack like XAMPP.