Download

How do I avoid z fighting on the meshes? (Video) NearClipPlane parameter doesnt help.

Hello guys,

I have a question about z-fighting. I’ve recorded short video about this:
https://www.youtube.com/watch?v=U_MB…ature=youtu.be

I’ve tried change NearClipPlane from 0 to 10 or 20 or even 100. Nothing happened. I’ve tried to save my project and open it again but the result is the same.

Could you help me please? Any other ways to fix that?

Thanks for any help!
Max

I don’t actually see any Z-fighting, if you’re talking about the aliasing-then you need to adjust the anti-aliasing settings in the post process volume. You might actually get some Z-fighting from that mesh, since you have the individual boars in front of a surface what will happen is that when you move the camera away at some point the surface of the boards will be at the same depth as the surface behind them, so in that case you would need to modify the mesh so that you don’t have two surfaces that close. But you could also just replace the boards with a normal map so you get those lines without having the geometry.

Hi darthviper107,

thank you so much for your answer! The map might be good decision but I need photorealistic quality of the boards.
I found this thread https://answers.unrealengine.com/que…ng-jitter.html

My problem looks almost the same. When I try to move my camera away I can see the “flickering” effect. I’ve just recorded another video with same issue.
https://www.youtube.com/watch?v=wxPd…ature=youtu.be

My camera is not so far from the boards but as you can see the left part have no Jitter or Z-fighting or AA issues, but the right part has.
I’ve tried to find the anti-aliasing settings in the post process volume but I cant find it there. Can I find this parameter in the Details Tab or Settings Tab? (screenshots)

Also I’ve tried to remove the surface behind the boards but it doesn’t help.
UE4.18.1

Max

Did you manage to solve the problem? I have the same issue and need help.

Thanks.