How do blueprint objects interact with lights?

Can anyone explain how blueprint objects interact with lights? From my (admittedly patchy) knowledge, if a model has a lightmap applied then only direct lighting will be dictated by a static light, is that correct? If so then can anyone explain why my scene looks the way it does? There are only two Blueprint objects in the scene and they are both showing up differently to the rest of the objects. Every object in the scene has at least a lightmap, most have normal maps. Both the blueprint objects have lightmaps (so they should react the same as the rest of the objects in the scene as far as I can tell) No object, blueprint or static mesh,has an emmisive applied.

Hey Hulkysaurus -

To directly answer your question, objects are always lit from a per object basis unless “Light attachment as group” is set to true which, by default, it is not.

It looks like your movable lights have very little indirect lighting influence or you static light shave too great an indirect lighting influence. What are your light settings and what is the world settings under Lightmass for indirect lighting influence?

Thank You

Eric Ketchum

Hi Eric,

Sorry its been such a long time getting back to you, so much to do, so little time! I’ve included the light settings below. I’m still having the same problem with all my blueprints; its like they are acting independently of all the lights in the level. This is going to be a major problem as the lights can’t stay as dynamic; the level will need to be ran on a tablet. Ultimately it would be great if I could get the lighting exactly as it is, but affecting the blueprint objects the same as the static meshes, which, as you can see in the first image, it clearly isn’t.

I’m aware that there is probably a massive hole in my knowledge here that I need to sort out. I’ve tried changing the lighting to stationary and adding lightmaps but that doesn’t solve the problem either. Any advice you can give me here would be a life saver,


Hey Hulkysaurus -

No Problem. I believe I may have a very simple solution for your issue. In the Blueprint, select your Static Mesh and under it’s details panel >> LIGHTING >> Advanced Roll Down >> Check Light As If Static to true. This should ensure that all meshes, blueprinted or not are lit in the same fashion with your static lights.

Let me know if this does not fix your problem -

Eric Ketchum

Hi there, where can I find “Light as if static” button in the 4.19 Unreal Studio version?

1 Like

I am still having the same problem with UE 4.27.2

The only thing that fixes it for me is switching Light Source (Directional Light) from Stationary to Static.