Download

How could i disable lighting entirely? Like every bit of lighting

My game i’m trying to make doesn’t require any lighting at all, all the textures and sprites would appear as is. Whenever i play the scene appears just a bit darker than in the editor, and in the editor it looks perfect. I’m trying to make my game look like this GH3 - Soulless 100% FC - YouTube and for that i don’t need any lighting at all.

1: Forward rendering 2:Make everything an unlit material, 3: Profit.

Make one base/master material that’s unlit, and derive all materials from it (as the guy above me suggested). But do not use Forward rendering. It will create more issues than it solves. Regarding the brightness difference, make sure to have unbound PostProcess volume in your level which has Exposure set to manual (Default is automatic) and EV offset to 0.

I agree on the “use a master material that is unlit” bit. It should also turn off shadowing. (Shadows can’t exist without light – they’re defined by the light surrounding them, as negative space!)

Also, remove all lights / skydomes from the level. That way, you should have an easy way to see what things will look like, and guarantee that anything you see is not from lights.