Download

How complex can a landscape material be?

Hello everyone,
please keep in mind it’s the first time i’m working with landscape materials and landscapes. I already saw some tutorials about this and found that usually people tend to use some rather simple materials for landscapes. I tried to use some more complex(?) one and got some weird results… Maybe it’s because i’m not setting it correctly? Dunno…

This is the material itself:

&stc=1

This is the blending part of it. (There are some wires connected to greyed out pins like tesellation because i was using some simple flat tesellation but deactivated thinking it would fix it but didn’t)

&stc=1

Then i just apply this material to the landscape material and go to the paint landscape mode. 3 layers are there and one is applied by default to the entire material.

&stc=1

Everything looks ok.

But then i try to paint selecting another layer. And this is what i get after some time with “compiling shaders” warning:

&stc=1

Then try selecting the last layer. Once again time for “compiling shaders” warning and get this:

&stc=1

NOTE: This happened at the time of writing. The times i tried before all i got was just that gray checker then can’t never paint again in that part, no matter what layer i select.

But if it didn’t happened before with the stone layer, this time happened when trying to re-paint with the default ground layer:

&stc=1

Only two things i can do after this:

  • Closing without saving
  • Click on the yellow arrow in the material for the landscape in the details panel to get it back to default (no material selected) and then reaplying the material again to get the entire landscape painted with the default ground layer.

So, am i doing something wrong? is this an engine problem? I’m using 4.7.3 by the way.

Thank you very much in advance for any help.

Paint the whole terrain ones. After this it should work correctly.

Thanks for your answer!

Unfortunately i tested it again just to make sure i didn’t tried this before but the result was the same:

-Get the whole tile where i tried painting again (after painting the whole terrain) in gray checker texture (just like in the last screenshot i posted earlier) and then nothing works on it. No matter what layer i select to try and paint in there nothing get painted.

:confused:

How many Textures you use. The Limit is 16, correct me if i am worng :wink:

You have to paint the whole terrain, not only parts that you have the Gray checkers. Gray out the Terrain and then Paint over it.

Yeah that’s what i did. The entire terrain went gray and then i can’t paint on it anymore :S

Texture Samplers: 11/16

(the 16 limit sucks but i’m still inside of it :/)

Make a Grayscale png Texture with a white background.
In The Paint Tool from the Landscape, there are the Layers. Right Click on it and import your png File. Try if this one works.

Ok, at first i thought it was going to work but then selected the grass layer to paint a little bit with it and again the gray checker and nothing gets painted in there anymore… :frowning:

Btw what does exactly loading that white grayscaled picture into the layers?

Normally you use the png file for the height of the texture, when you blend them. White should be the strongest one and cover the whole terrain with the texture.
I work with a Splatmap on my Landscape, that i don´t have to paint the whole thing for myself.

Oh i see, thanks for your explanation. Would be cool if i could use it xD

I tried simplying the material a bit reducing the number of instances for Texture Sample nodes but still teh same result. It works ok until i try to paint with the third layer (no matter what it is the order: first ground then stone then grass = gray checker, first ground then grass then stone = gray checker)

If you want, send me your project file (only the landscape with material) then i take a look at it.

Ouch! should of entered here first before touching anything else :confused:
I was a bit frustrated and deleted the material and tried with a really simple one which worked…
My bad but this confirms it was because the material was too much for the engine (or maybe for my pc to render it out?)

Anyways thank you very much for your help.

Ok, glad it works now :wink:

Good luck with your Project

Thank you very much!
And thanks again for your help :slight_smile: