How can Procedural Foliage LODs be changed?

Hello all,

I’m using the procedural foliage spawner volume tool to build a forest. The meshes that are generated keep disappearing when I zoom out too far, but because I want to have a big world, this is going to be a problem. I need the distant trees to remain visible.

I know this is an issue with the spawner rather than the mesh itself, because when I place a single mesh in the world next to the spawner, all of the trees in the spawner disappear while the lone mesh stays visible for a much much larger distance.

Here is a top-down view of the spawner with a lone mesh next to it:

And here is where the spawned trees disappear. The single mesh is still there and stays visible for a great distance.

As you can see, I can’t zoom very far out before the trees disappear.

I have tried changing the settings in the mesh, but it doesn’t make any difference to the spawned trees at all. There must be a way to change the LOD distance for spawned trees but so far nothing I try has worked. Also, I know that this isn’t because my system can’t handle more LODs, it is a good system and isn’t struggling at all with what’s currently happening.

Any help would be greatly appreciated.

hey, i had exactly same problem. fixed by changing lod distances in mesh and delete all trees. click one tree so it chooses all, click delete and resimulate. this doesnt delete the spawner, only trees you can just hit resimulate after. fixed for me, hope it works for you too.