How can I resolve an error when building on Ubuntu 14.04 LTS?

I’ve followed all of the instructions in the readme found here. Everything goes smoothly, up until I run ‘make UE4Client’. Here’s the important parts of what I see on the terminal, I’ve separated each line with a blank line:

Building UnrealHeaderTool...
 -export-dynamic -v -Wl,--no-undefined -rpath=${ORIGIN}/../../../engine/binaries/linux --eh-frame-hdr -m elf_x86_64 -dynamic-linker /lib64/ld-linux-x86-64.so.2 ......... (very long line follows)

ERROR: System.IO.FileNotFoundException: Could not load file or assembly 'System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.

File name: 'System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
  at UnrealBuildTool.UnrealBuildTool.ExecuteActions (System.Collections.Generic.List`1 ActionsToExecute, System.String& ExecutorName) [0x00000] in <filename unknown>:0 
  at UnrealBuildTool.UnrealBuildTool.RunUBT (System.String[] Arguments) [0x00000] in <filename unknown>:0 

Cumulative action seconds (8 processors): 0.00 building projects, 0.00 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other

UBT execution time: 1.56 seconds

ERROR: UnrealHeaderTool failed for target 'UE4Client' (platform: Linux, module info: /home/james/Desktop/UnrealEngine-4.1.0-release/Engine/Intermediate/Build/Linux/UE4Client/Debug/UnrealHeaderTool.manifest).

make: *** [UE4Client] Error 1

I know Linux is new territory, but it’s said to have worked in the Readme I was following.

Building natively on Linux is not supported yet. The only currently support workflow is to use the cross-compiler toolchain on Windows, then transfer the packaged game to your Linux machine.

Ahh, I misunderstood. Thanks!

Did you install mono and other pre-requisites, as your error suggests that mono library is missing?

That, however, does not mean that this should fail this early. Check if you have this installed: Ubuntu – Error