How can I move particle emitters without having them reset?

When moving my particle effect (by updating the actor that has the effect as a component with Set Actor Location in BP each tick), it always seems to restart the particle effect many times while moving which leads to stuttering. Any idea what settings I have to modify so that particles smoothly move around the level by playing full loops?

Thanks!

You can try and create a looping effect, and then use the BP expression spawnEmitterAttached. You can specify an ActorLocation in the location pin, or specify a socket or bonename in the Attach Point Name field.

Set the location Type to Snap to Target. You can play around with the setup/rotations etc from there to get the behavior you like.

Thanks homeRye, but that was not it.

I just found the fix: I had to enable “Use Local Space” under Required → Emitter of the Particle Effect. I think the problem was actually not that the effect resetted, but that it was using World Space and therefore the actor’s movement messed with the effect because it was not contained in itself.

It is correct, If it’s not set to Local space then the emitter takes into account world transformations which require the emitter to reset.

thanks this saved the day

The “Use Local Space” setting worked for me too, thank you!