How can I make an FPS scale in UE4?

I would use 4.19 but when I transferred over I lost some of my objects I created so I’m going to use 4.18 for this. is there any way I can make an FPS(frames per second) scale in my options menu?

What do you mean by FPS scale?

so people can change the fps of the game. some monitors can play up to 240 fps and some can only go as high as 24 or even lower. if the game goes at 30, people can change the fps to a higher number if they want to play at a smoother rate.

You can’t really force the Framerate to be greater than what the player’s devide can output, but you can limit it with this node (this will be saved when the player closes the game and reopens it):


it’s not working. I set it to 30 but couldn’t tell a difference. I put it at 10 to see if that made a difference. then I put it to 1 but I’m still seeing no change. I made sure that this event was hooked up to the event begin play node.

Try this one: Limiting the frame rate - AnswerHub - Unreal Engine Forums

still didn’t work. I also tried using these commands in a different level to see if maybe the command wasn’t working in just only 1 level.

Well, I’m afraid i can’t help you then :confused: i never used this myself…

what should I do with this page? should I mark something as answered, or will someone else come along and answer it?

Well i did what i could to help, but as long as you don’t mark my answer as correct, someone else should come along and help you…

ok, so I talked to my dad about what command he used for his fps. do you know if there’s a “Sync” command? I’m replying to you because I don’t think anyone else will see this question. I have seen other posts that haven’t been answered in years.

I’m not sure there is such a thing, but i just remembered something, have you tried saving the settigns from GameUserSettings after you set the FrameRate limit? It’s another node belonging to GameUserSettings.

I did see something about that but I can’t find that file. is it a .INI file? and where could I find it?

It’s not a file, it’s a node, you drag off of GetGameUserSettings, and type in save, and the node should appear:


would it be something like this?

Not quite, try getting rid of the second GetGameUserSettings|

got an error.

You have to connect the GetGameUserSettings you’re getting to that SaveSettings node :wink:

like this? because if I get rid of the target, it gives me an error so I’m guessing put it like this.