how can i have transparency blend? its either full opaqe or invisible

does anyone know how to have an opacity mask in ue4? that you know you can have in-between values etc

i also need it to have normal opaque shading
setting it to translucent removes lighting and it has no shading
its basically toon shading with opacity

how can i just have normal opaque rendering with blended opacity?
im just trying to do hair planes with opacity map

Switch the “blend mode” from “Opacity Mask” to “Translucent” and change the “translucency”-“lighting mode” options from “Volumetric NonDirectional” to “Surface ForwardShading”.
If the translucency rendering options are too expensive, consider using “blend mode” “Opacity Mask” and use the “Dither” function node. But it sometimes causes unwanted smearing.

the opacity works like this but the lighting is completely different and not correct for hair etc

the material is basically flat shaded now

i also dont have a blend mode called opacity mask