Download

How can I avoid this situation?

Below this question is a previous post describing the issue I’m having.

I’ve resigned myself to recreating the two floors for the structure I built. Because I’m forced to scrap what I already made to start over I’d like to know how I can avoid the pitfalls expressed in the post below. Is there something I can do, an approach I can take, that will help me avoid these errors (below) in the long term?

"I’m fairly new to unreal engines still.

I have a multi-level building. I just added a third floor (aka roof for the second level) and I’ve just begun getting this message: “Large actor receives a pre-shadow and will cause extreme performance hit unless bCastDynamicShadow is set to false.”

At present, it wasn’t always this way, the ceiling is pitch black. If I add more lighting to illuminate the ceiling it will be black again if I leave the level or exit and return.

When researching the problem, this forum as well as the unreal documentation, nothing has proven instructive or helpful toward finding a solution. The Doc’s offer " A large Actor has been set to cast shadows - this will cause extreme performance issues and should have bUseBooleanEnvironmentShadowing set to true."

I have no issue with these ceilings not casting shadows. My problem is that I can’t find where and/or how to adjust either parameter. I used the ~ to open a command line but I’m not entirely certain of the syntax to use to properly execute either of these parameters or if there is a way to see the entire code so I can search for each parameter. I also do not know which parameter is the appropriate one to use or if both need to be adjusted.

I’d really rather avoid remaking this item if it can be helped."

Thanks in advance.

ShadowIssue.jpg

What about the dynamic occlusion settings? Turn it up to 4 and see the results. Maybe the Lightbulbs are from it´s setting to low, try higher values.
Look at the settings on the left. Select all your lights an play around with the values till it fits for you.
Attenuation Radius is for all selected lights, increasing this value lights up the whole scene.
Place a Lightmass importance Volume in your Level also a Post Process Volume to set the colorgrading. This maybe can help.
UE4.jpg

I’m sorry, I’m still getting acquainted with the tools available to me, where exactly do I find the dynamic occlusion settings to adjust it to 4?

Well, I adjusted a bunch of the settings, though I never did find a specific one for dynamic occlusion, and it helped in the short term, but after building the lighting things returned back to the darkness in the picture. I increased every light’s shadow exposure to 4 and things looks perfect. Unfortunately when I build the lighting it all reverted.

I’m thinking my initial design, which looks pretty slick in my opinion, needs to be adjusted to compensate for this illusive “issue.” Instead of a 5 level high-rise I’ll go to a series of elevated platforms where none provide a substantial ceiling for the other. Very annoying, but sometimes you have to roll with the punches.

Thanks for your help.

Ok, i see…try to use an Sky Light in your Room and turn up the “Ambient Occlusion” or the Indirect Lightning from your Bulbs. These settings you can find in the detail tab. The SkyLights indirect lightning is called Ambient Occlusion and from the bulbs indirect lightning. Do your Materials have on the ceiling a lightmap? If they dont have they will be black.
You can also place a emmissive Material on a cube and plant it in your room to light up the ceiling. This works very well for me.
Wish you all the best for getting tje lights to work. The UE4 Engine is tough to learn i know this…but it has on the other side a a very good benefit for what you can do if you understand the terms.
I´m also at the beginning and i dont get the aligning tool to work proper for me. That´s **** anoying.

Best Regards

Thanks for the continued help.

I did manage to resolve the matter of lighting. I did so by adding a Lighting Importance Volume around my entire structure. Once that was in place and once I rebuilt the lighting, the problem with the shadow went away. I posted the link below. Hopefully people with similar issues will come across this link sooner than I did.

https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/Lightmass/Basics/index.html#lightmassimportancevolume

Thank you again.