Hot Reload problem - LINK : fatal error LNK1104: cannot open file Game-DebugGame.dll


I can’t hot reload my Project. The error that I get is fatal error LNK1104: cannot open file 'C:\ProjectPath\Binaries\Win64\UE4Editor-MyGame-Win64-DebugGame.dll'.

It’s only happening when I use the solution configuration “DebugGame Editor” It works fine if I use “Development Editor” but if I use that I can’t debug.

I have tried all the solutions I could find regarding this problem:

LINK : fatal error LNK1104: cannot open file - C++ - Unreal Engine Forums (this one just says “close” the editor, which is not a solution)
Cannot build project - LINK : fatal error LNK1104: cannot open file - Platform & Builds - Unreal Engine Forums

I tested my setup with other projects and it works fine.

This Is the UnrealBuildTool Log:
link text

I run a test, compiling all the Blueprints with no errors. And removed all the plugins but DungeonArchitect and Apex (which I think are not the problem)

I tried running Visual Studio as admin as well as checking if the file was read only.

No success so far.

Can anybody help me?

Many thanks.

1 Like

It’s funny,

I tested thousands of things but clicking the “Compile” button on the editor, and it works pressing it.

I still can’t Ctrl + Shift + B (or click build) on visual studio. Which I’ve been doing for years.

Is there a reason for this?

Was similar problem.
I solved this with these steps:

  1. In the game project folder remove “Binaries” and “Intermediate” folders
  2. Right click on .uproject file → “Generate visual studio project files”.
  3. Run the project and agree to build.

Had the same issue. For me the solution was to close UE which was still open with my project in the background

1 Like

thank you bro…worked for me