Hot reload not working

Hot reload not working if compile in VS 2017. Tested on new blank c++ project. Added class based on APawn - work fine. Added private attr

float test;

and initialize it in default created constructor as

float = 1.0f;

Pressed buid in VS - builded ok as expected, but in editor got errors:

[2018.03.13-21.59.33:201][908]LogHotReload: New module detected: UE4Editor-TestProject-333.dll
[2018.03.13-21.59.33:221][909]LogHotReload: Starting Hot-Reload from IDE
[2018.03.13-21.59.33:249][909]LogModuleManager: Warning: Module file D:/documents/Unreal Projects/TestProject/Binaries/Win64/UE4Editor-TestProject-333.dll is missing. This is likely a stale module that must be recompiled.
[2018.03.13-21.59.33:249][909]Warning: HotReload failed, reload failed /Script/TestProject.

In VS selected Development Editor configuration

Unreal Engine v4.18.3

Visual Studio Community 2017 v4.7.02556

Forgot to say - UE4 source from launcher.
And of course not float = 1.0f; but test = 1.0f;

Yeah, Hot Reload doesn’t work if you change the header file or stuff in the constructor. That is pretty much normal behavior.

Are you using solution configuration ‘Debug Game Editor’? I’ve just had the same problem after update visual studio and using that configuration and it was solved after changing to ‘Development Editor’…

Thank you for answer. As I already said

In VS selected Development Editor configuration

Thank you for answer, I didn’t know about that. By the way I tried change attr in BeginPlay(…) - same result. Also I didn’t created any instances of this class or any blueprint based on it.
Hot reload worked well some time ago in 4.18 version, I updated UE4 several times, updated VS several times and remarked that it is not working when returned to coding from modeling. Don’t know when exactly it brokes.

If you only changed 1 attribute in BeginPlay and it didn’t work, then the question is still open, because this kind of change should work with Hot-Reload. Sadly, it’s the first time I read about that behavior and my Hot-Reload in 4.18.3 works, so I can’t help any further.

I updated to 4.19 and hot reload works again :slight_smile: Im very happy!