Download

[HOLOLENS] Error Deploying app to Hololens 1 using engine version 4.24

Hi. Happy new year!

After installing all pre-requisites for developing and deploying for Hololens using unreal version 4.24 I was able to succesfully build for Hololens but when I try to install it via Windows Device Portal I get the following Error:

Failure reason: Unable to install bundle file:///C:/Data/Users/peter/AppData/Local/Microsoft/Windows/INetCache/UPD4B13.tmp/HololensTest.appxbundle because it does not have an appropriate application package for x86 architecture. Failure text: Package was not found. (0x80073cf1).

The settings I’m using are attached.

I’m using the Hololens 1 device, I don´t know if the engine version 4.24 is only designed for deploying for the Hololens 2 or is also available for Hololens 1.

Can someone please guide me a little what can I do to solve this problem or if I’m doing something wrong.

Thank you.

Sorry, Unreal 4.24 isn’t compatible with HoloLens 1 Gen.

Thank you very much for your answer. So for Hololens 1 the only thing we have is streaming the unreal PC viewport right? Is there any other thing we can make using hololens 1 with any other official version of unreal?

I just ran into the same problem. It’s really weird and disappointing that there’s no support for HoloLens 1 Gen. Thanks for the Q&A though.

I’ve ran into this today as well. Same error when installing; “**because it does not have an appropriate application package for x86 architecture. Failure text: Package was not found. (0x80073cf1).” ** Is there any way around this? Do we have to go back to 4.23? Trying to get a Hololens 2 seems impossible at the moment. Any help would be greatly appreciated. @Dyonisian [USER=“80677”]Carlos Flores[/USER] @AndreyChistyakov

I just solve the Deployment to Hololens 2 with Architect ARM64 package. “Microsoft.VCLibs.arm64.14.00”. Do understand that you guys having this problem sometime ago, if not than can try these step.

  1. go to UE launcher selecting “Option”
  2. on target Platforms remove Hololens 2
  3. close UE launcher when finished
  4. then going back to UE launcher and select Hololens 2
    wait unstill finished, and repackage Project…

Good luck!