Histogram Auto Exposure is miscalculating certain areas and turning them pitch black

I’m having an issue where the the Histogram auto exposure is turn as dark as possible in areas where is should brighten the scene and I can’t understand why. It happens in areas that are dark and I expect the expect the EV100 value to decrease but instead it jumps as high as possible, higher then when I look directly at the sun!

I’ve included some screen shots with the HDR (Eye Adaptation) visualiser on to demonstrate what I mean. In the first image I am getting the exposure value I would expect, it is a very dark area.

Then when I look down slightly the screen turns black, as though I were looking at something incredibly bright.

It happens in other areas as well, some are very dark but others aren’t. It also happens, in different places, in another lighting scenario for the same scene at night.

What am I doing wrong? Any help would be appreciated

what are the main lighting settings (directional, skylight, Lightmass)?

I’m using a stationary Directional Light and a Skylight and a Sky Atmosphere. I’m not so familiar with the SkyAtmosphere or how it affects the lighting.

I’m also using a single importance volume over the building that is the focus of the scene, but it extends safely past the edges of the building.

The Lightmass settings are largely default, except for Indirect quailty and bounces raised a little.

That are also a few stationary lights dotted around for fill but this issue was happening before I added them.

It might be the volumetric lightmap settings. If those are default, it could solve it to decrease Detail Cell Size and increase Maximum Memory Data. Try changing those by about 25% at a time, and test per change, or 50%. So, if Detail Cell Size is 200, decrease to 150 (25% decrease), and if Max Memory is 30 Mb, increase to about 50. The issue, from what I read in the doc for it, is if Detail Cell Size is lower, then the 3D grid of sample cells is denser (more lighting sample points per unit volume). Concurrently, Max Memory at too low a value results in the high-density sample points (nearer to surfaces) being culled and losing light/shadow data. Increasing Max Memory provides more memory so those don’t get culled near surfaces and areas where lighting/shadows require more memory.

Another possible cause is running out of texture memory somehow.

I looked at the settings you mentioned and I was actually using Sparse Volume Lighting Samples, however when I switched to Volumetric Lightmap and tweaked the settings as you described it still produced the same error, in the same locations so I think it is probably not a lightmass issue.

I’ll have a look at texture memory usage but I wouldn’t have thought I’d be running out yet. The change in lighting from one side of the object to the other is pretty extreme. On the exterior it is in almost direct sunlight and the inside is probably the darkest point of the whole scene, but I’ve tried putting a block in there to block the light and it didn’t seem to make a difference. But I get a similar issue in my nighttime lighting scenario in an out door area with almost no geometry so I’m really confused as to what is causing it there

When looking at something incredibly bright in a scene, it would be so bright to show as mostly or complete white (or tinted light color). It wouldn’t show up black unless there’s something else happening, such as a lack of memory or another resource to actually render the super bright area.

I think we’ve ruled out the VLM (Volumetric LightMap), and running out of texture memory. Is the project ray-tracing enabled? If yes, what are the settings at in the post process volume? Too high or low of samples in the basic or for other ray-tracing settings could have something to do with it. Not that it’d be the direct cause since some settings in combination can produce problems.

Someone found any fix for this? I have the exact same issue and I can’t get my head around it!!

Sorry not sorry for the necropost, but I think I figured this one out - it’s the HistogramLogMin setting, which is too high to capture all the scene detail. In a project I’m working on, we have relatively low intensity lighting, and this causes the nighttime scenes to have exposure values of around -10 to -12 EV, which is below the default setting (I think). Just decrease the HistogramLogMin setting and the weird AE bouncing should be fixed. You may want to vary this value depending on time of day, in case you want to avoid exposing for dark shadows in daytime.

If a lot of your scene is darker than the HistogramLogMin value, what happens is that as things get brighter, more of your dark bits get into the histogram, making the AE system think that everything just got darker, so the scene is brightened, and vice versa.

Took me a while. You’re welcome!

1 Like

Or… increase your lighting intensity to closer to real world values and the default Epic stuff will generally play nicer.

Doesn’t matter how bright your lights are as soon as the auto exposure target falls off the histogram range (such as looking at a dark shadow) the exposure is going to bounce.

I honestly don’t understand why they set the histogram log min so high, it’s all but a certainty the average user is going to run into this problem and have no idea whats going on and just want to turn auto-exposure off to solve it.

1 Like

Surely better to clamp everything at the min point rather than just dump the pixels? Well, what do I know…

1 Like

around what value worked for you? i have mine at about -40 but still having this exact same issue

-40 should easily work, are you sure you are setting the right value?


Might look different if you don’t have extended luminance enabled.

1 Like

yeah it wasnt the issue after all, i was able to fix it changing the target device post processing to match the game