HighResShot with Oculus captures at camera 0,0,0

Hey all. Got a strange problem that popped up in 4.17 that wasn’t there in 4.16. When using the console command hiresshot with the Rift it puts the capture camera down at 0,0,0, clipping into the floor or whatever else it is near. When using the Vive, it captures just fine. I’m not setting any variables between the two HMDs. Tracking Origin is set to Floor for both. Could that be it? I know it needs to be set to Floor for using SteamVR with the Rift or Vive. But perhaps with testing the project in Oculus it’s putting it on the ground?

Any ideas? Thanks!

Hi there,

I’ve got a similar problem, but in my case this actually happens when using the Vive. I haven’t tried screenshooting with the Rift so far, so I have nothing to contribute on that aspect.

So you had this working with the Vive in 4.16? I only started in 4.17 to use the HighResShot command…

So if it works with the Vive for you now, could you tell me how you managed to do it?

Some trials: When using the Rift I set tracking origin to floor level, but I don’t do that for the Vive. I don’t set a tracking origin for the Vive at all. I just played with this: it makes no difference to the screenshot result on the Vive when I change the tracking origin from floor level to eye level or don’t set it at all. Screenshot is always from floor level.

Next piece of puzzle: when I set the ‘base eye height’ in the Pawn to 180 (normally it is set to ‘0’), my view in VR is 180 units above the floor and my controller meshes are back down where they should be. So even though my eyes are now too high the screenshot actually ends up coming from 180 units below my eyes, so effectively from where I want it to be taken from.

What do you think?

Just tried this with the Rift:

‘shot’ takes a screenshot from my point of view in the HMD, but the two-eyed distorted image, which I can not influence.

‘HighResShot’ takes a screenshot of a normal image (maybe single-eye cropped?), but from world origin (0,0,0), which I can not influence.


From what you mentioned, joelgerlach, this has worked before, so I may just hope that it will work again in the next release and not spend any more time trying to find a workaround now.