Download

Highly visible seams on model that looks fine in substance painter

I’m currently on my phone so I can’t show pictures right now, however Ill upload some tonight.

I have some extremely obvious seams on my model, when it is imported into unreal, however it looks fine in both substance painter and Maya. Is this common or easy to fix? I’m using a height map, texture and roughness map.

I saw someone else with a similar issue get their problem solved by changing the ‘compression’ of the normals? However, I don’t know what they mean by this or if it will even help me.

As I said I will post pictures tonight, but if someone with experience in this could assist, will be greatly appreciated.

When you import a normal map texture to UE4 you need to make sure to mark it as a normal map–it will then use specific compression settings, otherwise it won’t render correctly.

Oh true, this isn’t something I’ve done before. I’m assuming it takes more than simply connecting it to the ‘normal’ slot on the material blueprint right? If you would be so kind, would you tell me how to do this?

I don’t have UE4 open in front of me at the moment, but if you double click on the normal map texture in the content browser a window will open with a bunch of options.
There will be a drop down box somewhere with options like TC Default, TC Normal map etc. (It’s been a few months since I’ve looked at it but it’ll be similar).

So just select the normal map option, also make note of the box where you can flip the green channel as it might come in handy.

Ahhh, thank you so much! I’ll give this a go tonight, and come running back if I’m still striking trouble. Really appreciate that :smiley:

You can also add “_normal” to the file name and UE4 will automatically detect that it’s a normal map when it’s imported and apply the correct settings.