Download

high reflections (but i have no roughness)

hey all -

so i’ve got a material in a corridor scene - it has no roughness applied - yet in the scene - it’s reflecting rater intensely!

what’s up with that? :slight_smile:

148110b10831d56ae2ca1e816b8b090b3a090003.jpeg

e70020d57ec74c24644bc2fbca27e5fe6f1f3902.jpeg

6a4353714d4b86c33865b7003b6bcccd36be1c8f.jpeg

So why not just apply a constant 1 to roughness and see if that helps?

Most likely the normal map is very bumpy and fine. This focuses highlights that otherwise would have been broad with the default roughness. In real life the more bumpy the micro-surface is, the more it will increase the overall roughness and scattering of light. In UE4, it is your job to make the roughness plausible for the given normal map.

Look up a method called “Composite Textures” and “Roughness from Normal”. basically you make a black texture of same size as your normal, goto composite options and set “normal to roughness red channel” then us that to add to your desired roughness.

This just gives a texture for how much roughness would be needed to match the normal.

@jonimake - yea, tried that already.
@RyanB - you are correct - seems the problem is with the normal. :slight_smile: thanks for the tips - gonna do some research!

also I just realized, if you are rotating the UVs of a normal like that, you also need to rotate the RB components of the normal map.

In fact it should probably work to use the same customrotate node again but use normal.XY as the UV input, then append the original blue channel to the output.

but make sure you change rotation center to 0 not the default 0.5 since normals have 0 as origin (engine unpacks from 0-1 to -1-1 range for normals under the hood).

btw see what happens when you stick the specular into the red base color node … for roughness i would set constant 0.5 as a good default.