Hiding actor makes parent sockets not working

I have a single player game project with an FPS camera inherited to Mesh in a Third Person project. Camera attached to parent socket ‘head’ in order to obtain true FPS feeling. Everything works fine when the actor is visible in the game. But I don’t want players to see the actor when they look beneath. Like Amnesia. I checked both ‘Actor hidden in game’ and ‘Owner no see’ seperate times each but whenever I hide my actor, camera’s attachment to ‘head’ is going away too. Camera is moving straight forward without any head movement after this. I want my actor hidden in game and also I want my camera still attached to mesh’s head. Can anybody help? Looked over 20 past threads but couldn’t find solution to this.

Can anybody help me?

Maybe it’s an internal optimization which doesn’t play any animations if an actor is hidden? In this case you could work around this by replacing the material on your actor with a fully transparent one (I hope you’ll find a better way).

spyro

Yes, maybe. You stated a fair point actually. I tried to do headbobbing with Camera Shake blueprint. I worked hard on it but couldn’t manage it to look good and real enough. Searched the web and couldn’t find any good headbobbing settings either.

Apparently, setting UE4Man’s material’s opacity mask to 1500 or so made the material transparent. This did the trick. Thank you.