Download

Hide Components

hello to the community!

I’m looking to find a way to hide some objects from the planar reflection. I think it may be possible with the hide component node but i’m not sure how to setup to make it work.

I have not found alot about the hide component node.

If we can’t find a solution to hide objects from being reflect from the planar reflection component. It make useful :frowning:
Maybe someone know how to make this work ?

There must be someone who stuck on this too !??

Sorry to bump… I really need some insight here, if someone have a way to make it work… my dealine is coming soon :frowning:

Is there other place i can look for a answer other then answer hub and this forum ?

I will appreciate if i can get a answer. Thanks

Is your planar reflection an actor in your level, or a component in an actor?

If you click on the planar reflection actor, and check its details, there will be an array called “Hidden Actors”, any actor you add here will not be reflected.
If it’s in the scene, you can directly set this array. If it’s a component you’ll need to get a reference to whatever object you don’t want to be reflected.

You might want to explain in more detail, what actor you want to be hidden, and where is this actor.

Hi Mosel3y!

Well i simply add a planar reflection in the scene, i tried as well to make a blueprint with the planar reflection in it, but i don’t figured out how to make it work (I’m a artist not a programmer) :confused: If i simply add a planar reflection component in the scene in the detail i didn’t see array called ‘‘Hidden Actor’’ like you said. I must do something wrong.

I was thinking this should do the trick doing it in the Level Blueprints direcly, but clearly… i’m doing wrong lol

2b867d4d34d23b606bac1c3d846bc77c9f5efe54.jpeg

Maybe this screen will help…64c8a3a5748633042bd19266b5ea3e0d6be4dcd2.jpeg

You don’t have this section in the details panel, with your planar reflection capture actor selected in the scene?

Ah! Well … no i assume it is not in 4,12. I should tell you this in the first place.

I’m working with 4.12 for my project.

Okay… so there’s no way to do this in 4.12.5 in blueprint ?

Ah, yes that option didn’t exist in 4.12.
However the method you are using in the blueprint should work. I have confirmed in 4.12

It will only work when you play the game obviously, or simulate, can you confirm it still is not working as intended when you click play?

No, it does not work in 4.12
As far as i can tell or maybe it could be, if someone more experimented than me know a way to make it work.

I will install 4.14. I don’t really like changing engine when i’m working on project. It could create inexpected problems sometimes :frowning:

But many thanks for your time i appreciate :slight_smile:

Strange, works fine for me. This is 4.12.5

The level blueprint:

Then when I click play, the floor is no longer reflected:

That’s odd! I made the same scene as you and i does not work :frowning: (Well not the same but a test)

See…

cc770ec8e044b8d2963878aba6c46ba4820a5f79.jpeg

Oh… it does work… but loll my problem is that the planar reflection continue to reflect on my stair but i want to exclude the reflection on the stair. Sorry i was not enough clear :s

So in your test above you want the stairs to appear in the planar reflection, but you don’t want the stairs to reflect the red plane? I’m not aware of a way of doing that, why do you want to?
Does the stairs actually need to be reflective? You could put a more rough material on it.

in my project if you refer to the first image i post… you can see that i have a lake with a planar reflection on it… but the problem is when i use the planar the grass(Ground), the stairs or other things on the ground become reflective. and it should not… the only way that i can get rid of thereflection is to delete roughness and specular on my landscape material. and it make the landscape not accurate etc… same thing for the stairs. The stairshave a concrete material on it and it must have some roughness and specular on it. The planar relfector need to be reflective only on the water.

Well, you could reduce the roughness without removing it completely, it looks like it may not be rough enough. Are you using a map for your roughness or a scalar parameter?

Also though, I have found that the Sun in BP_SkySphere can cause reflections even on rough surfaces when using the planar reflection, maybe try reducing the brightness of the sun in BP_SkySphere (I think you have one in your scene), the variable is “Sun Brightness”.

Actually you could try adjusting the “Distance from Plane Fade End” value on your PlanarReflection, reduce it so that it only covers the lake