Hidden Actor block mouse click event

Hi,

I’m currently working on a 3D interface, on 4.1.

when i hide a ‘widget’ (an Actor) i use this code :

		widget->SetActorHiddenInGame(true);   

		widget->DisableInput(NULL); // or with the active controller   

However, if an active widget is behind a hidden widget, the active one don’t receive the mouse click event.
From this thread, Can you disable actors? - Rendering - Unreal Engine Forums

hiding an actor seem to disable it entirely.

I use the ‘Event Actor On Clicked’ in the blueprint.

Edit :

I solve my problem using a different technique,
I keep an array of hidden widgets and use it with a line trace inside a WidgetManager Object,
The good thing is that I have only one object listening for the ‘mouse click event’ but I have to maintain this list.

for those who are interested, i linked the line trace segment of the blueprint