Download

Here's a simple question... (material tiling)

I know this is easy, but after searching for the answer and coming up short:

How do I change the tiling of my material? I’m using the default Water-Ocean material, but it is extremely stretched out over the plane.

I know the answer is staring me in the face, but I figured I’d ask anyway.

TextureCoord Node can be used to tile your textures.

When you open that material instance in the content browser, you’ll see Scale 1 and Scale 2 under Water section. Those are the tile values, and you do that with Texture Coordinate node inside the material.

Thanks for the quick replies.

Still a little confused. I don’t see Scale 1 and Scale 2, nor a ‘water’ section. Where exactly would I see that?

I added a Texture Coordinate node to World Position Offset. I’m not see a change in my scene. Does it go somewhere else?

Check out settings in Details tab

Sorry, i thought you were using the materials in Mobile project. Check out zeOrb’s post.

Awesome, found it. Unfortunately, it doesn’t seem to be solving my problem.

Take a look at the picture below. Drop the water texture onto my landscape layer looks exactly right. Even when I scale my material down, I’m getting that weird striping effect on the plane. It is perfectly square, so it shouldn’t be stretching in one direction. Why would the texture be getting applied differently?

Looks like you are only tiling it on the X or Y direction and not both of them at the same time.

There’s a walkthrough solution here on how to fix this problem, it’s a result of the default blueprint being unable to handle large scaling.

http://www.worldofleveldesign.com/categories/ue4/materials-starter-content-water-instance.php

I am having that same tiling problem. I watched the video of the link that TheR3Dking posted - loved every minute of it, and FINALLY learned how to create water (and make it look good)! However, if you take a look at my screenshot, it is easy to see the problem that I am having. I can add other materials, and they look great. But whenever I add this “Fine_Sand” Material that I downloaded from Quixel’s Megascans Bridge, this happens. Someone please help. Thanks!