Help With translucent Material on imported mesh, Please? :(

Hello everyone!

I have been getting this issue… and after days searching on google about it apparently no one else has ever had it or heard about it. I’m not sure if this is the right place on the forum, But I’m really out of ideas :frowning:

So In short:
When importing a custom mesh (FBX; Obj; Etc.) into unreal and applying any Translucent material, The object goes back to the default gray checker pattern and it doesn’t show any translucency. It only works again when setting the material back to opaque. But obviously with no Translucency.

Things that I have done:

  • The mesh IS properly UV mapped.

  • Used the basic Glass material that comes on the starter content. It Doesn’t work on my imported mesh but it does work on any geometry created inside unreal. For example applying in the default cube shape it works.

  • Tried creating a custom material. Changing from opaque to Translucent and applying my texture RGB to Base color and Alpha to Opacity. It still wont work on my imported mesh (Changes back to default Gray checker box) But it will work on a default cube shape.

  • I’ve tried installing both unreal 4.26 and unreal 5.0 and the same issue happens on both.

  • Tried on basic cubes and cylinders exported from Blender and also from 3Ds Max in multiple different ways (Objs and FBXs) (With proper Uv’s) And they all have the exact same issue when importing to unreal. I can’t apply the translucency.

  • Tried creating new projects too…And nothing

What Should I do? Anyone has any ideas? This should be something so simple, But for some reason I can’t find anything about it anywhere…

Peace.

Hi! I’m experiencing the same problem. I’ve seen your post dates back to August 21. Hope you have a solution you can share! Thanks

Also same problem, doesn’t seem like it would be a big deal but I think I’ve found the issue is related to Translucent materials not being recommended for mobile.
I created a new project not targeting mobile and added my same fbx and materials to it, it worked fine.
I’m not sure the exact project setting stopping it from working because according to the documentation while it isn’t recommended to use translucent materials it states they’re just not performant, which is not what we’re seeing.

I have had this exact same problem in UE5. Try un-ticking “Build Nanite” on the FBX Import Options box when bringing the asset in that you need to apply translucency material to.

7 Likes

You saved me, @Greggo! I wasted hours looking for a solution, and here it is.

1 Like

Thanks, bud. Helped a lot

1 Like

thanks man.

Apparently it’s a nanite bug for external fbx. thx

I hate that this is the solution, but I’m thankful to have it. Cheers!