Download

Help with Paper 2D pixel perfect camera

Hi everyone. Im working on a 2d space shooter and i got blurry pixel results. On game play event of PlayerCameraManager I set camera’s ortho width to viewport width. This solves the sizing problems and sometimes my player ship pixels looks crisp. But when i moved the camera pixels get blurry. I assume I need to limit (round) camera movement to get pixel perfect results. But I don’t know how to do it.

Probably Motion Blur, you can turn it off completely in project settings or adjust it by adding a Post-Process volume to the level and checking the ‘UnBound’ box.

I tend to drop the values from .5 to around .1, which works well for me. Also if you’re using 4.9, there are some issues with the new Motion Blur and TAA which cause a lot of edge-artifacts. I think it’s being looked into for 4.10 / 4.11