Download

Help needed --> Not able to get any smooth movement/animation/rotation at ALL in UE4

Hey there.

So I can’t get any smooth movement/animation/rotation in UE4.25.3 on Mac OSX 10.14.6 Mojave,
30" inch screen, 2540 x 1620 resolution, tested with two different graphics cards
( NVIDIA GTX680 4GB and AMD Radeon Sapphire Pulse 8GB) and
this is a MacPro 12-core (2x2,4 Ghz 6-Core Intel Xeon) 32GB 1333 Mhz-DDR3

No matter if we talk about camera movement, player movement, rotation on an object or whatever.
No matter which project, which demo projects or even the smallest tests.
I always see a small “stuttering”, no smooth movement.
I really noticed this when I double checked with other engines.
hen it became very obvious and since then drives me nuts.

Example: For testing I started an empty scene, removed everything, just put a cube in there
nd rotate it (with a delta seconds multiplier) frame rate is at 100FPS and
I STILL get no visually smooth movement.

I resized the editor to 1/4th on my screen, still the same. Tried r.screenPercentage 50, still the same.

(The Epic Demos “VehicleGame” “ShooterGame” & “ActionRPG” run on good frame rates
ere as well (around 45-50 on my system in fullscreen)
but I have the same stuttering when moving or rotating the player/camera)

I tried whatever I could find about frame stuttering (r.Vsync 0/1, switched between
forward/deferred rendering, enabled fast math for metal, etc)
I don’t know what could be causing this and this really drives me completely nuts
because this does NOT happen at all with Armory3D/Blender, Godot, Unity or Away3D. Even with heavier scenes.

(My suspicion is that this might have to do with Unreal using ShaderModel5 and
I am pretty sure the other ones do not? Any thoughts on that?)

BTW: I also get Screen Tearing on camera rotation. Often very noticeable.
his happens in Unity as well, even way more extreme than in Unreal.
ut then again, does not happen with the others…)

Any ideas what else I could try?

Thanks & best,
tL.

Okay, after hours and hours I managed to get rid of nearly all the issues. I am too lazy to write that all up here now.
However, one problem still persists:

  • I get a regular, rhythmic microstutter every 1/3 of a second or so when objects are moving. (Looks like a regular very short teleport)
    - This goes away when I play in wireframe or unlit mode.
  • This behaviour only shows in lit and lit_detaillighing mode.
  • t.maxFPS changes this behaviour: 30 for example gets rid of these regular “microdrops”
    but of course now the games don’t look smooth at all. (Looks like a consistent microstuttering now, not like before every 1/x second)
  • When I lock the frame rate to i.e. 30, the microstutter still appears in regular intervals, but the intervals are much longer.

Any ideas? I’ve seen a LOT of other people posting about pretty similar problems this.
But most of the time things changed for them with VSync or Frame Smoothing. Here it doesn’t.
Someone even suggested to turn off UDP Transport in UDP Messaging, I don’t know why that would help but I tried that as well already.

Because this goes away when I play in wireframe or unlit mode, I suspect something else is going on.
However, this also happens when I only have one directional light in the scene, no PP at all and no textures applied to objects.
So I am not sure what to do now.

(Keep in mind though that I still get a constant, very high FPS result…)