[Help] Moving some foliage types crashes editor

Hello, There are a few types of foliage that cause the editor to crash when I move them or manipulate them. All the other foliage types I have work perfectly, I just have the issue with a few types. When I select the problem types and try to move them the editor freezes then crashes after a few seconds. The foliage files are there and do reside in explorer. Thanks for any help you can provide!

Hi oxygencube,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps have you taken to reproduce this on your end?
  • Can you post your crash logs and callstack here? The logs can be found at \Unreal Projects\PROJECTNAME\saved\logs.
  • What foliage assets specifically are causing this to occur?

Hi Adam,

Does this occur in a clean, blank project with no additional content or is it limited to one project?
This seems to occur only on one project.

What steps have you taken to reproduce this on your end?
I load my map and try to move certain foliage types using the selection tool or indirectly using the sculpt tool.

Can you post your crash logs and callstack here?

Log

What foliage assets specifically are causing this to occur?
Pine_Med_02

Where are the positions of the foliage instances stored? In the type or the map? It looks like there is a miscommunication of data somewhere.

It is a custom asset. I have tried replacing it with a different asset and the problem persists. The asset is working well as a foliage asset in other levels. I have a firm belief that there is a problem with the array or location data.

Is the asset a custom asset or one you got from the learn tab/marketplace?

The second crash (sculpting landscape) is a known issue, UE-28926. I’m focusing more on the foliage selection, which I have not been able to reproduce. Do you see this occur with basic assets, such as the Editor cube?

Everything is working correct with 98% of our other assets so I would imagine that this would work correct with a basic asset as well. I have tried removing all instances of that foliage asset and repopulating them with the proc. foliage tool and I still get a crash when I try to move them individually. If I place them using the basic foliage painter then I am able to move them.

I have tried creating a new foliage type with a different custom mesh and still get the crash.

I created a foliage type with the engine cube and was able to move the instance.

Some meshes I am able to move one at a time but if I select multiple and try to move them I crash.

I spawned new foliage using same types, assets, and spawner on new map and am able to move single and multiple instances, but still get a crash when trying to sculpt terrain.

Can you explain to me where the position for foliage instances is stored? The level file? The foliage type?

As I looked into the known bug: UE-28926 I think they are related. If sculpting the terrain with foliage causes crashes… maybe it is trying to move the instances and throwing an error. Thus if I try to move them by hand it throws the same error.

Try generating a handful of different types of foliage using proc. foliage spawner or then move a bunch of them around.

Hi oxygencube,

Thank you for the additional information. This was reproduced internally and we have entered a bug report, UE-29242, to be assessed by the development staff.