Download

Help! Motion blur not working

Hi, I’m having trouble getting motion blur to work.
I’ve enabled it in project settings.
In the first person camera component in the FP blueprint, and in the post process volume, I’ve set the
Motion blur properties to:
Amount 1
Max 100
Per Object Size 0.5

The post process volume is enveloping all my geo.
The movement is driven by a level blueprint, but in the Motion Blur visualizer the animated geo isn’t yellow.
I’ve watched this video, which I thought was very clear:https://youtube.com/watch?v=r1BCJt22oHYAny ideas anyone?

A: Use infinite extent, dont just overlap your geometry, B: Increase motion blur amount to see it more, C: If you add motion blur, let people turn it on and off easily, pretty much zero players like it.

Thanks for the tips. Toggling the infinite extent didn’t make any difference unfortunately. And the Amount setting doesn’t go above 1.
Not sure what else to try.
I’m actually going for an exaggerated and unpleasant effect, good to know you can turn it off though, because I’ll need to control it from Blueprints.

I should add that the motion blur is checked under show > post processing, but I’m not getting motion blur anywhere, even when I make a build.
I’ve tried “play in selected viewport”, with simulate on and off.
The gun is yellow in the visualizer, but nothing else, and even that doesn’t blur. Although that maybe because it’s not moving in relation to the camera.

Sometimes a get a split second of blur on the gun at the start of play.
I tried changing the settings from the level blueprint the way it was done here:
https://answers.unrealengine.com/que…6671/view.html

But again no luck.

I got it working for the camera at least, just not the animated geo.
Here’s the link:
https://forums.unrealengine.com/deve…eprint-new-way

As you can see below the cloud geo isn’t showing up when I simulate it in the editor window.

Not simulating:

Simulating:

I got it working sort of.
This is what I did:
https://answers.unrealengine.com/questions/435740/collision-on-post-process-volume.html
I made a box the child of the cloud geo to test it, and it works on the box, just not on the dynamic material of the cloud geo.