[Help] Light Leaks on solid static mesh

hi all,

not particularly new to 3D design but i am rather new to archviz in unreal 4 and I’v been trying to fix this issue.

I have what seems to be light leaks throughout the mesh.
in this particular case the walls are one solid piece then there is the ceiling another piece and the floor is another.
the light leak by the edge of the wall i don’t understand at all, as the UVs are attached and the wall is one solid piece. as for the light leak at the bottom of the wall, it’s the wall that is sitting on top of the floor but these meshes are flush with each other and i don’t understand why the light leaks through.
I’v read that this may be an issue with wall thickness and thickening out the wall does make it go away but… looking at the lighting on the floor its still leaking under the wall just not reaching the other side, and also this is built based on blueprints and that is how thick the walls are and i cant really just decide to make them thicker.

I’v been looking for ideas as to what i can do for the past 2 days, so if anyone can point me in the direction as to what to read to clear this up i would be suuuuuuper thankful :slight_smile:


1 Like

Your floor/walls/ceiling all need to line up in the corners exactly. If you have a plane for the floor and it goes underneath the wall then the lightmap can’t line up exactly where the wall is so you get bleeding.

Also, your lightmap UV is not good, looks like you used auto flatten UV’s and that always gets poor results, it ends up with too many unnecessary splits and in an ideal situation you want your UV islands to be similar in size for best results. If you do them manually, you can make sure that those small islands don’t get separated out as much. Also, for long surfaces, like if you have a very long wall you can split it half in the UV’s (add a segment there to the mesh if you don’t have one so you can split it) and that will help utilize space better.
Rule of thumb for lightmap UV’s is have the least number of seams and try to make your UV islands similar in size. In some cases you can just resize the small islands to be bigger even though they won’t be in-scale.

The thickness of the wall is one thing but it might also be due to light map resolution etc. Also having global illumination turned up highlights any light leakage as well so that might be one thing.

You might also want to play with the light settings in world settings as well. Hope I gave you at least some help.

Well for anyone interested in archviz and unreal i found this gem

well, i found my answer here

soooooooo… thx anyways unreal community XD

thanks! i actually did use auto flatten for that particular uv and i already did the unwrapping myself but it was to no avail. the light leak, i believe, had more to do with distance than UVs because the leak on the wall seam is actually a solid UV(dont know if that makes sense), its part of the same island as the adjacent wall. but yeah, Uving myself actually helped a lot on some other artefacting that i was having.

anyways, the article i posted earlier actually cleared up all my lighting problems, although it did raise light build times tremendously, and the results are wonderful.