Help, light changes color when I press play

Please Help. I have a level that changes color when I hit play. I have deleted EVERYTHING and put in a simple floor, 1 light and 1 cube brush. No post process volume, no color grading. Game mode set to default. Everything set to default.
And still, after I compile it looks fine, but if I hit play, it turns purpleish.
It started happening after I finished a level for an architectural visualization, so i need to fix it instead of redoing everything in a new project or level, so I duplicated it and started deleting everything to find out the problem. I can’t. If a start a new level it doesn’t behave this way (hit play and lighting seems fine)

I think it must be level specific, but I can’t find what I must have changed. Please Help!!

And you did not change the colors of the light in your Level Blueprint? This also happen when you delete the light and put a new one? Weird, since you also have no post processing. Maybe something about the material, can you show it or is it a simple texture on the Unreal BSP?

It’s not material related, all materials act the same. I deleted all lights and meshes, volumes and skylight, then created a new box brush and put a point light. Everything is default. But I still get the purplish hue. Is there a way to copy all the meshes from one level to another? Not duplicating the level, but get all the level meshes from one level to another, sort of a copy-paste method. Any ideas are appreciated, thanks

Yeah sure, just select all the meshes in your World Outliner, ctrl+c, change the map, click on the root of your World Outliner and ctrl+v.

Hey, if you have any more questions let us know. If you don’t, make sure to mark your question as answered! <3

I tried everything I could think of, but couldn’t make the level work correctly again. The only fix i could come up with was to use the copy-paste method to a new level. Created an empty empty level, and copy-pasted folder by folder, including all lights and effects, and everything worked as expected. If I ever find what was wrong I’ll post it. but this is a work around for now. Thanks for the help!