Download

[HELP] DK2 not working after 4.8 update

So i have not been able to use DK2 since 4.8 was released.

I updated the firmware and drivers for the DK2 and i have tried both Extended and Native modes but nothing works.

At first i just got a greyed out ‘Simulate in VR’ button then after i updated the firmware the button is colored in but when i click it i just get a blank viewport and the DK2 headset does not activate (light stays orange)

I tried the DK2 again with other software and it works fine - Is there something I’m missing?

Any help would be greatly appreciated, thanks in advance!

I had this problem also and I think I fixed it by uninstalling the Oculus runtime then verifying my ue4 4.8 install and then reinstalling the runtime. Well it was something like that I cant really remember the combo that got it running again.

For 4.8 you need SDK version 0.6.0.1! No previous version will work properly.
Are you using Nvidia? -> Downgrade driver to 350.12
Is your tracking camera or rift or both plugged into an USB 3 port -> plug into USB 2

If it still doesn’t work, come back here :slight_smile:

I checked all of that first and everything was up to date, i also tried both USB 3.0 and 2.0 but i did not try rolling back my NVidia driver so i will give it a try tonight - Thanks!

I actually ended up doing a reformat of my OS drive since i had a hard drive fail a few months ago and it had some old install path references which might have been effecting my Visual Studio install.

Still not working!

I rolled back the video card drivers, did a full reformat of my OS disk, disabled SLI, re-updated the firmware and swapped the usb and HDMI positions

I also just noticed that Direct to HMD does not work at all on any apps for the headset, it only comes on when it’s in Extended mode…

The blue light on the camera comes on every time in Direct mode but the light on the headset stays orange.

Any ideas? Below are my system specs:

**- Core i7 980 @ 3.33ghz

  • 24GB Ram
  • Windows 7 Pro 64 Bit (Latest updates)
  • Dual MSI 560 TI 2gb Twin Frozrs**

I noticed that when I use 4.8.1 (haven’t tried with other versions) and have blueprints open, VR preview doesn’t show anything on my Rift DK2, but as soon as I close down all blueprint windows, it works as it should. Now I don’t remember which runtime version I have and I’m not currently at work to check it out, but this might be worth trying.

CharlestonS, I have no idea. Maybe of your graphics cards are unsupported. Can you try your Rift on another system with a more recent card (I know it works with a GTX 660 and of course 970/980)?

I and a friend suffer the same problem, I have old card (560 TI) but works without inconvenience in U4.7

Did you try to manually deactivate the CPU graphics in the device manager?

I’m not sure if I understand you, if you mean about integrated in motherboard I’d already deactivated direct in the BIOS, in the device manager just appears the Nvidia adaptor

Looks like the fault is if there are a widget viewport (overlay) active

So the DK2 now works in other VR apps just fine in Direct mode and now when i try to run VR Preview in UE4 it actually crashes with an error log which is below, any ideas - I noticed that it is referencing *D:* but i don’t have a D: drive…

Fatal error: [File: D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 651]
Rendering thread exception:
Assertion failed: ViewFamily.RenderTarget->GetRenderTargetTexture() [File: D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Plugins\Runtime\OculusRift\Source\OculusRift\Private\OculusRiftRender.cpp] [Line: 141]

KERNELBASE.dll {0x000007fefd43b3dd} + 0 bytes
UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() {0x000007fee5f47c0f} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FOutputDevice::Logf__VA() {0x000007fee5e010b8} + 159 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FDebug::AssertFailed() {0x000007fee5dd1e72} + 65 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-OculusRift.dll!OculusRift::FViewExtension::PreRenderViewFamily_RenderThread() {0x000007fed54fad45} + 0 bytes
UE4Editor-Renderer.dll!RenderViewFamily_RenderThread() {0x000007fee1620f30} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Renderer.dll!TGraphTask<FRendererModule::BeginRenderingViewFamily'::17’::EURCMacro_FDrawSceneCommand>::ExecuteTask() {0x000007fee15e1321} + 18 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FTaskThread::ProcessTasks() {0x000007fee5c8651e} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FTaskThread::ProcessTasksUntilQuit() {0x000007fee5c8674d} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-RenderCore.dll!RenderingThreadMain() {0x000007fef34a5d3b} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-RenderCore.dll!FRenderingThread::Run() {0x000007fef34a624f} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FRunnableThreadWin::Run() {0x000007fee5f469e8} + 0 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() {0x000007fee5f3188d} + 8 bytes d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\sou
kernel32.dll {0x00000000773b59cd} + 0 bytes
ntdll.dll {0x00000000775eb981} + 0 bytes
ntdll.dll {0x00000000775eb981} + 0 bytes

really strange. have you compiled from source or do you use the launcher version?

(the “d:” comes from epic and their buildservers, nothing to worry about)

Glad to hear that the D: is an Epic thing but yeah, i use the launcher version and i need it to work without a compile version.

Everything was fine up until 4.8 came along.

mmm… strange… running out of ideas :slight_smile:

can you compile a new “blank” project with shipping configuration and alt+enter into rift mode? maybe this works and it’s “just” an issue with the vr preview…?

I’m having the same problem. How do I install the older nvidia 350.12 driver?

I tried rolling back to a previous driver but I cannot even tell which one I have installed right now.

This what I see in Device Manager:

latest driver.JPG

When I go to the Nvidia website to find drivers it won’t even let me download them!?

can get 350.12 driver.JPG

After all the time I’ve wasted trying to fix this I think It would just be faster for me to redo my project in Unreal 4.7

Can you download from this link?
http://www.nvidia.com/download/driverResults.aspx/83819/en-us

I’m actually getting a similar error, using 4.8.2 compiled from Github.

One day I came into the office, and the Oculus Runtime just started crashing. It would have nothing but a black screen, and when I’d click that black screen… the runtime would crash and I’d get “57493-Public TCID:158609 is not responding”. I boiled this issue down to a problem with the latest Nvidia drivers, and had to roll back all the way to GeForce 347.88 before it would work correctly again.

Despite that, UE 4.8.0 refused to load anything VR related (neither Preview nor Standalone), continually crashing with this error:

I updated UE to 4.8.2, and it gives the same error.

Opening projects in previous versions of the engine seems to work. For example, a project I have in 4.7.6 works just fine.

I wouldn’t bother rolling back the drivers, it didn’t do anything for me - I think this is just an issue that either Epic or Oculus have to address.

But if you do want to roll back your drivers you can find the legacy Nvidia drivers here - http://www.geforce.com/drivers/beta-legacy

After you have the drivers downloaded you would want to go to** Control panel** > Uninstall Program and look for Nvidia Graphics Driver then uninstall it.

**Restart **your computer then Install the legacy driver then Restart again.

As stated in my post, rolling back the Nvidia drivers did not solve UE 4.8.x crashes.

Instead, it solved a different problem I was having, a crash in the Oculus Runtime 0.6: “57493-Public TCID:158609 is not responding”.

The Unreal 4.8 error is the following, and yes, it’s probably a fix for Epic:

Rolling back your Unreal project to use version 4.7.6 should alleviate the issue.