Download

Headset/camera vertical position incorrect using SteamVR

I have a pawn in my world and running in “VR preview” mode gives positional and rotational tracking. The problem I am having is that in order for my eyes to be at proper eye height in the capsule, the headset has to be on the floor IRL.

That is, the camera’s Z position has the capsule’s eye position as an offset. I have tried setting the eye heights to 0 but that didn’t help. Setting the eye heights to -88 (which is the half-height of the capsule) has the problem fixed.

Is this normal or am I missing something?

You need to switch to seated tracking space.

https://docs.unrealengine.com/latest/INT/BlueprintAPI/SteamVR/SetTrackingSpace/index.html