Download

HDRI doesn't generate "direct" shadows in my scene ?

Hi everyone,

To train mysefl on diffferent way to enlight a scence, i opened the level “Advanced-Lighting” in the inclued scenes of UE4.

Theire is an HDRI in this scene and a directional light. I want to use only the HDRI as a source of light so i desactivated the sun intensity, but sadly this HRDI doesn’t generate any “direct” shadows (like that for exemple : http://www.aversis.be/tutorials/vray/images/free-vray-high-dynamic-range-hdri/hdri-preview-render-overview.jpg)

I did read about this verry interesting topic : Lets make Lightmass EPIC (and understandable) - Architectural and Design Visualization - Unreal Engine Forums
And they use HDRI to test. And they have shadowing. What whith my scene ? Why i don’t get any shadows with the “HDRI Epic Courtyard Daylight” on this Advenced Lighting scene ?

Thanks to you,

++ :slight_smile:

Are you baking lighting?

Yes yes, in production quality.

Edit : i dont wait hard direct shadows cause i disabled the sunlight itself from the HDRI and the directionallight, but the HDRI is still activated and i can play with it power totally. I wait just smooth direct shadows from it. As in the 2 exemple from my last links (last post).

Yes true, same with me. Can anyone answer this question, please ?

Hi!

Could you attach your render and your lightmass settings?
With proper lightmass settings + lightmap resolution + postprocess it’s doable…