Download

HDRI backdrop issue

I’m trying to us the HDRI backrop actor in my scene and since using it, I’ve noticed some strange floating shadows all the way around my model raised off the floor. I’ve swapped HDRs, changed settings in Lighting, AO, GI and nothing has fixed it.

HighresScreenshot00001.jpg

Can anyone offer some help on this please? What am i doing wrong?

Will

I had a similar issue once, and wasn’t using an HDRI backdrop, only the default skylight cubemap. It could be the LPV interfering with the shadowing/lighting. Try disabling it using a command in the console, so put a 0 instead of 1.

ConsoleVariables.ini

r.LightPropagationVolume = 0

If it’s not that, check mesh distance field settings in the directional light, and in World settings. Check cascaded shadow maps in directional light. Certain settings can cause weird artifacts, though it could easily be a case of lightmap mixing with other lighting methods.

One other possible cause is something with the Volumetric Lightmap. If the Maximum Brick Memory isn’t high enough, then cells (bricks) get culled and result in inconsistent shadowing. So, if Detail Cell Size is set at 100 instead of 200, then increase Maximum Memory per cell by double or so to ensure consistent shadowing and its resolution.

Thanks for the help presto!

I just checked all those you mention here but had no luck, then I switched my floor off and realised it was something with the static mesh of the floor. Yet, I did have a look at your response on another recent post you replied to that mentioned the Distance Fields. I switched Generator to ON in my static mesh editor details panel and that fixed it but completely disappeared. Now, I thought I want some shadow from the floor as you would, so switch the generator back to OFF and brought the Distance Field Res Scale down to 0.2 and that gave me some but not total overkill like in my first post. Have i made problems for myself here or have i hit the target on this one.

Great tip btw, thank again!
wjb

You’re welcome. I’m not sure yet, though it sounds close to the solution. Another potential cause is the volumetric lightmap (VLM) settings. Change those by decreasing Detail Cell Size and increasing Maximum Memory to get finer detail with more memory allotted for each VLM cell so it doesn’t cull too much of the outer cells. The VLM generates 3D cells, similar to voxels (like a pixel but 3D or cubic unit in 3D space), composed of lighting sample points at the corners of the cells. The default Detail Cell Size is 200, in Unreal units, which is kinda large, so decreasing the size brings those cells down to a smaller scale in the whole VLM grid. Hence, there’s more light sampling points, which requires more memory per cell (Maximum Brick Memory). High-density bricks at the periphery of the higher-density areas near surfaces are discarded until Maximum Memory limit is met. If the memory isn’t high enough, it results in inconsistent lighting and shadowing, especially near / on surfaces like the walls. Here is the page for VLM:

https://docs.unrealengine.com/en-US/…aps/index.html

It supposedly increases build times to modify the settings extensively, yet I wouldn’t worry about it unless the values are extreme (like Detail Cell Size 2, and Max Memory 500 or 1,000). One other note, I think it has to have a Lightmass Importance Volume to function completely. VLM can be visualized under Show button > Visualize > Volume Lighting Samples (shows distribution of light sampling points in the Lightmass Importance Volume). Might help to visualize the Importance Volume too, which is under Show > Volumes.

As for the distance field generation of the floor, it could be due to GI or other light settings. I’m thinking the mesh distance field of the floor (the newly generated one) at a low resolution (0.2) isn’t influenced by the HDRI backdrop as much as the shadows are without the distance field. What are the mobility settings of major lights in the scene (not spot/point lights, but only directional and skylight)? If there’s stationary lights it could be a part of the issue, though doesn’t mean stationary can’t be used, rather modified somehow to get it working. Stationary lights have distance field shadowmaps calculated by Lightmass, which don’t function well for area shadowing (soft shadows based on distance from object to shadow receiver and light source angle/size). There’s a few other things, but I’ll reply to your next post with it.

Hi!

If you’re looking for an easy tutorial about using HDRI lighting maybe you can try this:
“How to achieve shadows with a single HDRI in Unreal Engine”
http://www.majart.ie/tutorial/tutorial.html

…or if you need specific help please share your light’s/lightmass settings please!
Also the lightmap uv and its resolution /of the mesh(es) that receive bad shadows/…

IMO: if you want to use any distance field related visuals you’ll need to use a dynamic light.
Dynamic lights don’t produce GI!! So if your main light (Sky) doesn’t generate global illumination then your whole scene will be off…
Judging by your screenshot you’re after more realistic lighting + it looks like a mostly static scene, so I’d stick with static/stationary lights because they produce the most realistic lighting!

Actually, with an HDRI backdrop it is built for dynamic lighting. When adding the backdrop to the scene, it generates a movable skylight, and in the page for it there’s a warning about needing to delete an existing skylight so there’s not two different ones messing with the HDRI brightness and lighting/shadowing. So stick with dynamic lighting, wjb, and that way you’ll be capable of utilizing distance fields and cascaded shadow maps more effectively without altering the HDRI’s influence on things so heavily for every change. A few questions for you too:

  1. Is there a ground plane in the scene (the dome HDRI comes with one, but I don’t know if the other types do)? There needs to be one to accurately calculate lighting and shadows for the geometry and so it all blends well with the backdrop’s lighting.
  2. What are the backdrop’s settings? There’s a few settings that are pivotal to having a correct result in terms of shadows like the ones that are problematic currently.
  3. Is there a directional light in the scene? If so, what are its settings? Take a few screenshots of the Lighting settings in its details panel, and also include the transform values (Location, Rotation, Scale, with Mobility too). If there is a directional and its set to Static or Stationary, then it’s probably mucking things up somehow. That’s what I had when I tried building from a 3rd person shooter template level, and when I changed the mobility of the directional light to movable, I was able to change settings and remove artifacts in shadows.