HDR Compression & MipMaps Conflict?


I’m making use of a baking node to bake a material, which are saved with HDR compression. By default these have no mipmaps. I’ve tried to change this to sharpen0, but this results in them displaying as very low res in the level editor.

I can’t seem to figure out, whether they are very very slowly loading in or not, whether this is HDR conflicting with something. I’ve tried enabling ‘never stream’ which seems to load them in full res again, but this is obviously undesired.

Oddly enough, for all the baked normal maps which have normalmap compression, mipmaps can be enabled without the same low res problem.
I can’t seem to switch the reset of the baked textures to default compression without getting ugly green artifacts all over.
Anyone have any ideas?