Download

HDR Compression & Mipmap conflict?

Hello.

I’m currently using baked textures that I’ve saved from render targets. These are saved as HDR compression, with no mipmaps enabled. I’ve tried to enable sharpen0 for mips but for some reason it results in really low res textures. They still look fine when editing the settings, but in the level editor they’re blurry and low res.

The same doesn’t apply if I try any other compression mode, only HDR. But sadly all base color baked textures appear ugly with artifacts if they’re using anything other than HDR.
Does anyone know how I could get around this? Is there a way of saving render targets as something other than HDR, or allowing full resolution mip maps for HDR?

So I come back about 20 minutes later, and the textures are loaded in full size. I disabled never stream and the problem gets fixed. I can only assume there’s a conflict between streaming, mipmaps and HDR. Though I still don’t know what it could be, as other compression settings still load fast and fine.