having trouble with oculus rift and vr template

I am aware that others have had this issue before, and I have tried many of the solutions suggested on the forums and in the tech support question search, but I still can’t stop my vr character from being stuck mostly under ground when I play the template, even though a couple of weeks ago it was perfect. I am a bit tired of trying all the suggested tweeks so I was wondering if there was another template that someone knows about that I could use for my oculus rift. Thanks!

Which version of the Engine are you using? Have you modified the standard VR template or are you using it exactly as out of the box? I assume your Oculus Rift has been properly setup and calibrated. When you play in the editor and move physically from your starting position, can you see the Oculus Guardian? Where does it sit? On the level floor or much lower?

Thanks for the response. I am using various versions, now I am using 4.17.2 and also playing around with 4.18.0, and had up to very recently been using 4.16.x
. I have had the same problem with all versions. I have recalibrated my oculus several times in the VR hardware setup to make sure that was not an issue. And I have no problem at all running any other games, and I really do have a lot of VR games, possibly close to a 100. It sits basically sometimes underground, and I can see the hands very very slightly above the floor. I don’t think I see the box of the Oculus Guardian, but I have never seen it really before. Other VR things on the market work perfectly fine such as VRGun Toolkit, Old_Library, Weapon Master VR, etc. I hope this helps, and the reason I want to have this template work is to do some tests and learning. Thanks.

Can you try with the attached minimal VR project for 4.17.2? Are you still sitting on the floor or higher? Note that it has no touch controllers nor locomotion, it is just to test which height you get once you are in VR.

Perfect height! How can we go from here!?

Good! This means your HW works properly within UE4 and the problem is probably in the template. Next you should try this.

In 4.17.2 make a brand new project based on the standard VR template. Once the project has been created, edit the Event Graph for the Motion Controller Pawn (assuming you are using the Motion Controller Map) as shown below.

Note that the correct name for the pin is OculusHMD, with no space between Oculus and HMD, even if the Switch node will show it like it has a space in between.

When you edit a switch pin name its output is disconnected and needs to be reconnected manually, so don’t forget to reconnect the OculusHMD output to the top Set Tracking Origin node (the one which sets it to Floor Level).

Now it should look like this.

With this change the standard VR template should work as expected with your Oculus Rift. Hopefully the bug in the template will be corrected once and for good in the next releases.

There was also another issue introduced in 4.17 I believe that affected tracking. This wasn’t nessesarily linked to the height, but also gave some annoying issues with initial tracking if you were not in your correct play area space when the Oculus headset began tracking.

A fix is in place for 4.18 which you can check out here:

Omg that worked!!! Thanks so much man. I spent so many hours on that darn thing and the fix took 10 secs lol. Thank you so much man!!!

Thanks for that info Dune I’ll look into that too. I am just so happy I got the template working again!!!

@malosal You are very welcome, happy to have helped you. :slight_smile:

My god, I’ve been dealing with this problem for hours. Thanks, I had the same problem and it totally fixed it!

This is great thanks!