Download

Having trouble playing a SoundWave in a MetaSound

Hi, I’m trying to play a SoundWave in my MetaSound, however, when I hit play no sound is played and the amplitude meters on the side don’t move. Here’s my setup:

MetaSoundWavePlayer

The “On Finished” event also never gets fired.

This is one of the simplest actions to perform with a MetaSound… so what am I doing wrong? Is there a setting in the Wave I need to change?

Thanks in advance

Didn’t try metasounds yet, but you should set an output at On Play, not On Finished. On Finished is to do something after the wave asset finished to play, not to play it. But maybe I am wrong, all are assumptions.

In my MetaSound, I have the “On Finished” pin of my Wave Player attached to the “On Finished” output pin of the MetaSound source. It works like an “exec” pin in Blueprints. With way it’s set up, I’m telling the MetaSound that it is done when the Wave finished playing. If “On Play” is linked up with “On Finished”, it just stops immediately.

The hot-pink pins are the actual audio.

I’m 99% sure this is a bug. It only happens on Linux, not Windows.

@NachoMonkey2 Same issue I had and I solved it. Here is the workaround: [SOLVED] Metasounds workaround: Wave not playing