Download

[SOLVED] Metasounds workaround: Wave not playing

I had a simple setup like this but nothing was playing when I press Play.

So the workaround is to promote the wave asset as graph input and then assign your wave as the default value.

Unfortunately, doing that did nothing for me… Are you sure you didn’t miss a step?

You can try checking these settings in when you click general at the top near to the stop button.

Sounds weren’t playing for me either until I had toggled these settings.

image

Changing those didn’t make anything change for me

No that was exactly I did. Nothing else. Did you promote the asset as input and assign a default value?

Yeah, that was also what I did, when you set the wave asset as a default on the WavePlayer it doesn’t play (for me at least).

But when I made it a input variable and assigned it to the waveplayer it’d play no problem.