Download

Having trouble getting things looking right in Rift mode

I have tried exporting projects I’m working on and closing UE4, tried the marketplace samples, messing with resolution and graphics settings… Whenever I press alt+enter after launching a project I can get into rift mode, but here are the issues:

  1. When moving around or turning my head, the entire scene blurs from some sort of post processing effect that I can’t seem to turn off. It’s very disorienting and strains my eyes.

  2. I’m not sure if it’s due to this blur, but I can feel the sensation that the left and right eyes are not synced properly immediately upon turning or moving. (I don’t have issues like this in unity at all)

  3. The 3D effect does not appear to be as prevelant as in Unity, probably also due to the blurring. I definitely don’t feel as “present” when viewing 3d models in UE4. I don’t know what is wrong.

  4. There is a ton of latency when I shake the rift up and down (even with vsync off) the view seems to bounce around. I am usually able to resolve this issue by disabling vsync like in other applications. The headtracking latency is noticeably high.

If anyone has any advice on what I can do to improve this please let me know. The blurring when turning, post processing effect, and very high head tracking latency are the main issues at this time. I tried a sample demo posted by a user on a subreddit hoping it was my settings, but it looked even worse. I have set resolution to native 1280x800, etc. I know it’s not this PC, it is pretty powerful and I don’t have this issue anywhere else. Any help would be greatly appreciated (Even the mobile demo appears to have this blurring issue when moving around and left and right eye sync issue) It feels like I’m using a hacked driver right now… It’s that bad.

For example, in the mobile demo when moving towards the stairs I can feel a sort of quick “convergence” sensation between my eyes. And when I look closely I can see that everything blurs for a second which could be causing the issue I’m guessing.

Hi, did you know there is a VR Example Level with custom VR character blueprint? Just open the Content Examples project, then Open Level -> “VR.umap”.
It’s a simple “demo” room with a statue in it but that helps it run at a reasonable frame rate.

I totally notice this as well. I believe this is some kind of bug. To demonstrate, open the VR level above and view using the Oculus Rift. If you stand in front of the statue and move back and forth while looking at it the textures on the surface seems to split and blur, making your eyes feel like they can’t converge. When you stop moving it seems fine.

It seems to be a texture related thing. I’ve noticed if I use a model with materials that don’t use textures I do not notice it. for example the character hero model in the default content.

I would love to hear anyone else’s experience with this.

I made an entire blockout today and it looks great, but no textures so I’m not sure. I’ll test it out with materials/textures later.

I was able to create a screenshot demonstrating the issue (although in VR it’s MUCH more disorienting!)

It appears as though the textures seem to “vibrate” when you are moving your character. I also notice it (or something similar) happening when I press the PAUSE key on my keyboard. The textures seem to blur and vibrate the same way if you let it sit paused for a few seconds. Again it’s very disorienting for VR.

EDIT: when you pause with the PAUSE key rotate your headset a few degrees, that definitely brings out the ghosting/shimmering. I also noticed when I tried the “shooter” market place content it has an option for “Low” quality graphics in it’s in game menu. On “Low” quality this issue doesn’t appear.

Again, when you stand still everything looks good, as you move surface textures vibrate and shimmer and your eyes have difficulty converging.

Thank you for reminding me about the VR sample level, totally forgot about that. Yes the statue splits and blurs terribly. Good screenshot there also.

You have precisely described the issue I’m encountering. I am suprised this has not been posted yet. Hopefully this will be resolved soon because it makes for a pretty uncomfortable VR experience. “Shimmering” textures is the perfect word to describe this. It creates that sensation of your eyes trying to converge/focus.

On a side note: I would also like to know how to adjust the prediction values for the headtracking, I can’t find it anywhere. There are several factors combined that are killing the immersion for me.

Total spitball: Could this be related to temporal AA? Have you tried enabling/disabling AA or changing the AA type?

I only seem to be able to do that in the editor. How can I disable temperal AA in standalone game mode?

Edit: So apparently the way to do this is through a post process volume in the scene. Under Misc I changed AA Method to FXAA. It does remove the problem, but at (the expected) loss in scene quality versus temporal AA. Since resolution is spread across such a wide field of view in VR we need all the image quality we can get. The ideal solution would be to have full stereo TemporalAA working. Hopefully that’s something that can be fixed.

Thank you boon/tmek, this worked perfectly. For a bit more instruction. For those having this issue go to the scene outliner on the right, Click on the post process effect, then below that in the details pane scroll to “Misc” (I had to click the little down arrow to show more after that because it was hidden) Then for AA choose either fxaa or none.

So basically temporal AA and rift mode don’t play nice yet.

This does not fix the issue for me. I can play my game regularly on my pc with extremely minor performance issues, but as soon as I switch into rift mode, the entire scene lags incredibly slowly behind my rift rotational movement. It’s impossible to even navigate, as even walking forward jumps sporadically on the rift display.

On a sidebar, after packaging my game and opening it, pressing alt+enter does nothing. I can only enter rift mode by launching a standalone play session from within the viewport window, and then pressing alt+enter to activate the rift. Any ideas why? It’s sure to be something simple.

Hi Jonny5, it seems you are having different issues than this thread originates with but I might be able to help.

Make sure you aren’t packaging with the “shipping” build configuration. That disables the developer console and alt-enter toggling fullscreen.

As for performance issues in standalone I only get about 40-50fps on the “Blueprint Office” demo in VR mode with a GTX 760, VR mode is expensive. One thing that might help is minimizing the editor window after launching the standalone window (to make sure it’s not doing double duty rendering the editor and the game).