Download

Having problems with my first mod

So I’m just trying to edit existing creatures/items for my first little mod.

My first test was with an Amarberry, trying to make it stack by 200 and weigh .01

Cooked the mod, set my server to use the mod,loaded up in game, the amarberries didn’t seem to be anything different.

I’m quite new at this,so thoughts?

EDIT: FIXED

Here are some things that you need to do:

  1. Open the TestMod file and on the right side, find the PrimalGameDataOverride. Set that to your PrimalGameData file.
  2. What you have done is created a new berry, not modified the older one. You’ll have to replace the existing amarberry in your PrimalGameData with your PrimalItem.
    These are the very basic steps, but after that you will need to copy a few more files into your mod folder to allow it to work.

Also I noticed that you seem to have posted this exact same thread twice within a few hours. Just be patient and wait for someone to see your first thread, don’t make so many.

Sorry, I didnt notice the other thread actually went through. Thanks for the help.
It seems I did the first step,but not the second. Do I need to give it a different blueprint name then replace it in the master item list?

EDIT: I see that there were two amarberries i could link it to now, trying the one from my mod’s directory out.
EDIT2: Picking from bushes, the berry is the same as the old. Still not sure what to do.

Somewhere there should be a file that involves the bushes and their harvestability. I’d try to find it for you but i’m unable to use my computer atm.

I found a file that sets what can be picked from the bushes, and replaced the amarberry there, but it didnt seem to do anything?

Man, with all this trouble over a berry,i dont even want to imagine dinos

Edit:Not sure if i should mention this, but my dev tools dont have any newer dino(Mosasaur and such)

Did you download the DevKit from steam or Epic?

-WM

That’s a tough question to answer. I first tried steam and it didnt run,probably missing files and such. Then I downloaded it via Epic, that worked, but it would go in an infinite ‘compiling shaders’ loop when i tried copying a file.

So then I followed a youtube guide, downloaded it off of steam, then extracted the dev kit from the github zip.

The DevKit needs to compile the shaders - especially the very, very first time you run it(it also happens when loading maps) and that is because otherwise it will render nothing and you will see nothing.

It’s not an infinite loop, it can take anywhere from a couple minutes to an hour or more, depending on your computer. Same thing happens whenever you open the devkit and open a primalgamedata file - the devkit will freeze(not responding) - while it loads the reference tree into memory, which can also take a considerable amount of time depending on the computer.

The steam devkit is out of date, and the binaries will not bring it up to date.

If you insist on using the steam devkit, you will need to download the “diff content” available here on the forums, it’s a pinned topic on the main page, in addition to GitHub.

Otherwise, use the Epic devkit and updates, while not timely, are self-contained and you gain the very-much-needed ability to verify the DevKit.

-WM

Thank you for your info, it’s good to know.

I have a 4.0 i7-4790k processor with 16GB of ram,it was using all 16GB of memory and hadn’t moved for about 30 minutes, so that’s normal?

I cannot remember correctly, it’s been a little while - I’ve been modding since early August.

If it was the very first time you ran it, then I would suspect yes. I know the first time I ran it, it took a little more than an hour or so I believe, I don’t know the ram usage.

The CPU isn’t all that important. The DevKit mainly relies on RAM and storage read/write speeds. The lower the amount and speeds of those, the more significant of a drop in DevKit responsiveness is to be expected.

-WM

I appreciate all the help so far!

Any chance could someone explain a detailed how-to edit an existing item or dinosaur? Like what specific files I need to change and such?
I’m a little confused on what I have to end up replacing, for example: A berry, Do I need to edit the bushes then to give the new berry?
if so, do i need to edit whatever file(which i’m looking for) that tells the game what bush to use?
When the berry is changed, do i need to wait for the bushes to be replaced ingame? Are the changes immediate and all existing berries of the same type
immediately different?

EDIT: I got the newer devkit, from the epic games installer, to work. It seems to be,relatively,caught up.
The Berry still didn’t ‘work’ as far as i can tell.
The Server uses GameModsIds= in the launch batfile, so i’m sure it’s being loaded.
Here’s some screenshots to hopefully explain what ive done so far.

After this,I choose ‘cook game mod’,not map,not total conversion.
I set my server to the mod ID, subscribe to the mod, add it to the active list in the main menu, join my server.
Hope this helps.

It could maybe be server related,I’m not sure. Documentation is scarce and limited on mods.
start ShooterGameServer TheIsland?ModId=560762437?SessionName=SconeIsland?INSERTMORESTUFFHERE?listen?bRawSockets
exit

I’m noticing that you made a child of the amarberry file. Maybe if you just copy the PrimalItemConsumable file and modify that it’ll work. I’m not entirely sure, but I think that it might help

My original test used a non-child version, on the older devkit.

DId you use a non child version on the new dev kit?

I just replaced all child versions with raw copies. Still nothing.
Anyone else got any input? I feel like I need a moderator or something. Then when it works, I’ll make a full documentation(that isnt half a year old) on setting up a mod, because this is silly.

That would be great. Try PMing one of the moderators. This seems to be beyond my knowledge.

Apologies for the difficulty, I really want to be able to make a mod too.

Bump. No response from Moderators yet.