Having issue with static lighting bakes - Lightmass flips normals ?

I’ve always had these issues with lightmaps on low poly static meshes:

This one is really apparent and right in my face, so to speak. In Blender face normals are perfectly fine. If I re-import FBX into Blender (or anywhere else) - normals aren’t flipped. Normals also appear how they should be in UE4. UV maps are non-overlapping. However, after baking lightmaps, I get that issue.

On water-tight meshes, having checked Recalculate normals works sometime and eliminates these artifacts. On non-manifold meshes I was unable to figure out how to get a rid of those artifacts. Some non-manifold meshes get lightmapped just fine, some - not so much :frowning:

Any idea how to fix this ?

Thanks

Your light-map MUST be wrong. can you share a screenshot of it.

Also, 2 things to do.

set the faces to smooth,
mark the edge(es) as sharp,
add the special transform tool to the mesh for the angle - Edge Modifier, unclick Edge Angle and leave it there.
When you export make sure that the experimental option apply all transforms is clicked.
In Geometry tab of the FBX exporter change the smoothing group to Edge.
On Import into UE4 select MikkT space import normals.

  1. Set all faces to smooth,
    set the side face to flat
    In the export Geometry tab change smooth group to Face
    On Import into UE4 select MikkT space import normals - anyway, even if it might not matter/apply.

Mind you, if your light map is bad this won’t change a single thing. The face in question on the light-map has to be all in one piece to be able to get the correct lighting across all of it without artifacts.
I can’t tell exactly what your mesh even looks like, but I’m fairly certain that if Lightmass builds is as a black triangle, your section of the UV map is incorrectly separated from the rest of the face.

You probably want to read all of this and absorb it if the issue is your UV Map

Light UV channel is definitely an area of work that can always use betterment for me and my meshes.

[USER=“3140864”]MostHost LA[/USER]

My UV maps are fine. The issue is Blender’s FBX exporter.

Finally got to the bottom of this last night, thanks to @Luoshuang !

Basically selecting Tangent Space option in the Geometry tab of Blender’s FBX exporter breaks tangent bounds in FBX and causes this issue. After I unchecked that option and re-exported my "problematic"meshes, artifacts went away (after rebuilding lighting).

Sounds improbable. I have a high end project built with meshes exported with the option on and not a single issue. Maybe the import settings were conflicting compared to what the FBX was and the way it was imported?

FBX files had broken tangent bounds, that’s the fact. I tried all kind of import settings and nothing changed. Funny enough some meshes never had any issues when they were exported with that option on and some appeared broken, somehow.

Either way, not using this option eliminates any issues and I don’t see any downside of not using it when exporting static meshes.

P.S. I didn’t have any issues with meshes that had normal map. These ones don’t have anything but flat color on them. Maybe having normal map vs not having one makes a difference when exporting with Tangent Space from Blender ? (e.g. lightmaps are calculated taking normal map tangents into consideration and not mesh tangents?)