Has anyone had issues with hair not showing?


Hi (i’m on a mac). In the MetaHumans blueprint for Irene and in the scene, Irene has no hair. I’m got the groom and groom alembic plugins enabled. In the materials there doesn’t seem to be hair.

Wondering if anyone has enountered this.

Thanks

2 Likes

Mine shows up but unfortunately the materials arent working

Check any warnings on the metahuman hair you selected. Some do not have hair cards yet and so only work at LOD 0 or LOD 1. This means if the character is not very close to camera they will be bald. So get very close or switch LOD to see if thats the case

1 Like

open the character blueprint and select LOD sync force (on the left ) change to 1 (on right) and compile then save.

4 Likes

Thx all for replying. Yeah tried forcing to LOD 0 and 1 but still no luck. Will try another character/human and see what happens. Cheers.

I have a Mac and was experiencing the same issue. You’ll have to select hair that is not based on strands. According to this link, hair simulation is disabled on Mac and needs to be investigated.

2 Likes

same problem here, the problem also extends to eye lashes. Ie. Hana

Someone told me to delete the lower quality lods of the face skeletal mesh. It worked with a female’s hair from disappearing.

But i am having trouble with beard and moustache on a man.

same issue here, I am experimenting on the Bernice model. She is missing head hair, showing some eyebrows but mostly not there. No signs of skin hair either.
i have gone through and manually changed the LOD for the head hair and still nothing. can anyone shed some light on the solution???

running UE4.26 on M1 mac mini

I had a similar issue on Ubuntu 18.04 where the hair renders in editor but disappears after packaged :frowning:

I heard a solution is to go to your hair groom asset and set the lod selector from cpu to gpu

How do you go about setting the log selector from cpu to gpu?

I had the same problem on ubantu.Did you solve this problem now?

Guys this should be the solution: you gotta set view distance at far or epic in the engine scalability settings

1 Like

Has anyone found a fix for this in UE5 Release?

I had an issue where the hair was not appearing. For me the error was due to plugins not being activated. This vid explains what plugins and project settings you need for it to work.

When I imported the metahuman into ue5 from quixel bridge, it prompted me to enable these plugins but it didnt actually do it.

hopefully this is helpful to some people.

1 Like

why delete reply?

Somehow I fixed the hair blinking issue and no longer felt my post was valid. But I have no idea why the hair was blinking or how I solved it…

Also experiencing this with metahuman hair that only supports 0 and 1 lods, but I cannot find official guidance on how to properly set these for use in-engine without forcing a lod level for the whole character. Doing so does not seem like good idea for performance reasons, and seems like overkill to fix the hair.

I tried deleting the higher lods for those hair meshes, with mixed results and some build errors. Is there a better way to do this?

You can change the bounds scale of the body and face to 10. Select the Metahuman and in its details select the body and face and change the value from 1 to 10

1 Like