Hard shadow edges

I just reinstalled Blender 2.76b, for model creation, and edge smoothing / face smoothing on low poly models does not work at all.
Does someone know if there is a way of blending shadow on model edges in game, using blueprints? Is that possible to even do that at run-time?

…working example or explanation would be greatly appreciated!
Thank you,


You sourcelight is set to stationary? is your foliage shadows set to movable?

Hi Filipe - thanks for replying.
You mean setting this object as movable? Just took a screenshot, this is what I have.

…also, in case you need it, this is my material for the model.


Your material is ok, I just asked about changing the foliage actor to movable to see the difference of the shadow, try to do that and rebuild. I´m sure that the shadow will be much better.

I noted that any foliage that moves with the wind must be settled as movable to avoid weird shadows… try and let me know pls

…ok, well… guess I’ll have to change some sizes here (lol), but for my leaf plant, I’m still seeing those sharp curves. I’ve played couple of videos on blender fbx import to UE, but I have a feeling my problem is with importing properly exported non-rigged model. My sun light is static (no movement), with height-based fog, so there is no other problems here… just need to find corrent way exporting from blender. If you know how, that would be great!

Hi, your sun light is static? Try to change it to stationary and your leaf mesh to movable to see if we have any change.

The only way I found to get rid of the hard shadow edges on round objects (pipes, trees, etc) with a movable directional light is to increase the “Dynamic Shadow Distance MovableLight” in “Cascaded Shadow Maps” until you don’t see any artifacts anymore.


Thank you guys for trying.
After catching some zees, I went back to Blender, found out that for some reason my export fbx settings got messed up. I ended up reinstalling application… with a fix to my problem!

Here’s what was preventing my shaded model to export properly.
Note to self… sleep regenerates brain neurons cognitive communication!

Actually, cascade shadow maps add hard edges to objects, almost making them seem like they dont have smooth normals. If you do encounter this though and want to use cascade shadow maps, I discovered that setting the console command of r.shadow.csmdepthbias and using a value of 50-100 works quite well in removing the hard edges.