Download

Hard problem with shadows - pls HELP!

Hi!

I have a big problem with shadows. I’ve studied all topics about dynamic shadows, cascades shadows, bounces etc. etc. Nothing work… I’m creating a house visualization from art project and it’s really annoying. Look on pictures:

(i used SHU cause server doesnt pass me trough)

1.) Closest:
http://scr.hu/1jmr/o4wzs
2.) Little further:
http://scr.hu/1jmr/o782u
3.) Normal :
http://scr.hu/1jmr/4z1xr
4.) Further:
http://scr.hu/1jmr/qgxru
5.) Farthest:
http://scr.hu/1jmr/qrooa

I need to have really sharp shadows and ofc they must be longer ;/ i have only first floor here but on all house roof etc looks really bad

Look:
1.) Under Roof:
http://scr.hu/1jmr/6hm7q
2.) Close to the roof and look in the room:
http://scr.hu/1jmr/t3zi0

S1 can explain me how to repair this ?? I worked on engine from 4.7 to 4.11 and same on everyone.

For best results for architectural visualizations use static lights. If you use dynamic shadows then you have to adjust the shadow bias setting which will get the shadow to line up more closely for objects on the surface, but may cause artifacts.

It’s really dark :confused: i dk why…

http://scr.hu/1jmr/wydbh

Weird:
http://scr.hu/1jmr/ztv33

Your lightmap resolution is too low which makes the shadows really large. You can adjust the lightmap resolution for each object by opening the static mesh from the content browser and changing the lightmap resolution. Or you can select the mesh in the scene and use the Lightmap Resolution Override which will apply to just the object in the scene. Also, you can add some environment lighting from the sky using a Skylight or going into the world properties and adjusting the environment in the Lightmass settings.

Which is optimal ? I have for all meshes overrided light map Res on 256 , is that good ?

I’ve combined like u siad with shadow bias and it looks great really thanks!
But my question right now is:

  • Can I increase that distance of converting shadows ??

http://scr.hu/1jmr/cgigb - this looks ok
http://scr.hu/1jmr/w4dph - little furhter and looks weird

U know what i want to resolve? right? Im going to present that project and its changing my shadows on distance nubmers… I dont want that option :confused: Is there any way to disable it? Skip it ?

It depends on the mesh, you want to keep the resolution as low as possible, but some things need higher resolution than others. If the mesh is particularly complex, then can require a higher resolution, if it’s not complex (like a floor) but needs high detail shadows because of the things casting onto it then it would need higher as well.

So what i need to do? :confused: to get the best results which I can only get from UE4 ?

And it’s looks weird.
http://scr.hu/1jmr/2ql5l

I have on my mesh straight edge and on shadow waving ;D this is normal or am i doing sth wrong ?

Stationary with the directional light though.

Increase the lightmap resolution of the surface. Also you should increase the light source angle so that the shadow won’t be that sharp.

****… I dont know how to resolve this… Could you help me ?
http://scr.hu/1jmr/ybov9

And this is screen from changing light source angle:
http://scr.hu/1jmr/zkb27

I’ve changed from .1 to 1,2,5 and even 500 and nothing works… Does light source angle work with static lighting only ??

When i set a shadow bias that resolve my problem with roof, sth like this was created:
http://scr.hu/1jmr/swel8

S1 can explain me how to set an optimal settings to light and world setting lightmass to have a best quality and performance ?? I dk what am i doing wrong :frowning: