Hands in VR template stopped working. No teleportation, no grab animation

Hi everyone,
I’ve been using the UE4 VR template for over a year now and had never experienced this. For some reason, my VR hands stopped working on every project I have. The tracking works fine, I can see and move my hands, but the teleporting and grabing functions don’t seem to work at all. I was originally working with version 4.18 when the problem started. But after upgrading to 4.20 the issue persists. Even within the Motion Controller Map on fresh new projects, both on 4.18 and 4.20, so is not an issue regarding migration of projects to a newer version. I must point out that outside UE4 the controllers work just fine.

I’m really looking for some help here, as I ran out of options on how to solve this. Been digging like crazy but I just can’t find a proper solution.

Has anyone experienced similar problems?

Have a similar issue with 4.20. Using Vive Controllers teleport isn’t working. If I bypass the “ProjectPointToNavigation” node, the teleport works. If I go through that node, the value is always 0,0,0, no matter where I point the controller. Maybe I am doing something wrong?

I am having the same problem, but with a Unreal Studio project not 4.20.1 in particular. My other vr template in 4.20.1 works fine. I believe some of the blueprint nodes have been renamed, and we need to replace them with the new ones.

I am finding yellow warnings all over the place. For example under Left Hand Teleport Rotation, the “Get MotionControllerThumbLeft_Y” node needs to be replaced with “Get MotionController (L) Thumbstick Y”. I have not figured out how to fix the InputAction Grabs or InputAction Teleports. I found some more warnings inside HMDLocomotionPawn as well, inside the Get Thumstick Facing Direction function “Get TeleportDirectionUP” and “Get TeleportDirectionRight”

Have exactly this problem in 4.20.2, with a brand new project created using the Virtual Reality Blueprint, HTC Vive. Without making any changes at all I simply play in VR, sometimes I can teleport once or twice and then it stops working, and the hand grab also stops working. How do you even start to debug this sort of thing?

I don’t think Epic cares.

I fixed this by deleting the MotionControllerPawn saved the project and closed unreal.
Then open it up again and add the MotionControllerPawn again and configure the Auto Possess Player to ZERO . This worked out for me.

Here is a potential fix that worked for me:

So I’m new to Unreal Engine having tried it on and off over the years. Perhaps this may help someone in the future who is also new and also run into this problem (this happened to me with Unreal Engine 4.25, 4.26 and 4.47):

So you’ve create a project from the “Virtual Reality” template and started playing around. One day you open the editor and the VR controllers completely stops working for your project. You can’t even see the controllers and none of the buttons or joysticks work. When you create a new project it works but not in the old one.

What I found was that some of the example content you import from your library (for example one of the Epic Paragon characters) will override all your inputs under your project settings, clearing all the VR specific input settings. An easy way to fix this is to Export the input settings from a new working project and then to import it in your old project.

Here are the steps:

  1. Open or create a new project from the Virtual Reality template.
  2. Perhaps run Build just in case.
  3. Go to Edit → Project Settings → Engine → Inputs
  4. At the top right there is an Export and Import button, click on Export.
  5. Save the .ini file to your Desktop or where-ever you prefer.
  6. Close the new project and open your old project.
  7. Go to Edit → Project Settings → Engine → Inputs again and click on the Import button on the top right.
  8. Import the .ini file you previously exported, you should notice all the VR specific inputs again.
  9. Now, safe everything by clinking on File → Save All in the main menu and restart Unreal Engine by closing and re-opening your old project.
  10. Finally, build your project and it should work as it did in the past.