Hands don't show up in VR Preview

Hi All,

I just started experimenting using Oculus hand tracking in unreal. I have enabled the headset hand tracking option and also unreal Oculus VR plugin hand tracking option. I have also checked the Oculus hand tracking examples to look at the proper setup.

But at this point I can see the hands are tracked but no mesh gets rendered when I VR preview the scene using Link cable. I only can see the Oculus icon and menu option icon when have my palm facing up, but no hand skeletal mesh shows up!

I was wondering if any of you know what is wrong?

I’m using UE 4.26.2

Thanks in advanced,
Ehsan

1 Like

I’m very new to this kind of development, and even newer to VR but I thought perhaps what little I know might help a bit.

I’ve just moments ago enabled hand tracking in my project to see what it would do.

I’ve created a new VR Project, and opened the provided “Motion Controller Map”. (enabled hand tracking) I too can see the oculus menu icons appear when i turn my hands around to face me.
My 3d Hand mesh appears and tracks the location & rotation, but not the initial rotation of my hands. By that I mean i can wave my hands about and rotate them but they are facing the wrong direction.

I think the ‘BPMotion Controller Pawn’ blueprint, which is already instanced in the scene but renamed as: 'VRPawn" (from memory), calls the ‘BP_motion controller’ blueprint which appears to have the 3d meshes attached.

So assuming you’re trying to use the default blueprints, I assume youve either not used the ‘BPMotionControllerPawn’ blueprint at all, or forgotten to set it’s ‘Auto Possess Player->Player 0’ value.

Good luck! I’m trying to do the same thing.

3 Likes

Thank you for your response, but I’m not using the template. I have my own project setup, but it worked after setting the confidence factor in the Oculus Hand Component to None. I’m not sure if that is the right solution though.

I know it’s been a long time ago, but I’m having the same issues as mentioned here… i can see my oculus icon and menu option but my hands won’t show at all. I’ve applied a custom mesh and still wont show my hands. Is there any other solution to this?

Please check if openXR plugin is enabled. If it is enabled, disable it and try it works for me in 4.26.

Did you find a solution for this?
@NitroCourt, I have tried disabling openXR but it also disables oculusVR with it.
The message I get is this:
“This plugin is required by OculusVR. Would you like to disable it as well?”
image

How do you manage to disable openXR only but keep oculusVR plugin?
Also, does this work in package-build game?
Thank you.

For anyone having trouble, this guy has good video tutorials on activating Oculus hand tracking in various UE versions. Check him out.

For anyone still having problems with this, set the XR API to “Legacy Oculus SDK (no longer developed by Epic)”

I had the same issue and chose auto-possess player 0, and that fixed it.

1 Like